Как посчитать сумму в Экселе

Как посчитать сумму в Excel быстро и просто? Чаще всего нас интересует итог по столбцу либо строке. Попробуйте различные способы найти сумму по столбцу, используйте функцию СУММ или же преобразуйте ваш диапазон в «умную» таблицу для простоты расчетов, складывайте данные из нескольких столбцов либо даже из разных таблиц. Все это мы увидим на примерах.

Содержание

Как суммировать весь столбец либо строку.

Если мы вводим функцию вручную, то в вашей таблице Excel появляются различные возможности расчетов. В нашей таблице записана ежемесячная выручка по отделам.

Если поставить формулу суммы в G2

=СУММ(B:B)

то получим общую выручку по первому отделу.

2020-01-06_6.png

Обратите внимание, что наличие текста, а не числа, в ячейке B1 никак не сказалось на подсчетах. Складываются только числовые значения, а символьные – игнорируются.

Важное замечание! Если среди чисел случайно окажется дата, то это окажет серьезное влияние на правильность расчетов. Дело в том, что даты хранятся в Excel в виде чисел, и отсчет их начинается с 1900 года ежедневно. Поэтому будьте внимательны, рассчитывая сумму столбца в Excel и используя его в формуле целиком.

Все сказанное выше в полной мере относится и к работе со строками.

2020-01-06_7.png

Но суммирование столбца целиком встречается достаточно редко. Гораздо чаще область, с которой мы будем работать, нужно указывать более тонко и точно.

Суммируем диапазон ячеек.

Важно научиться правильно указать диапазон данных. Вот как это сделать, если суммировать продажи за 1-й квартал:

Формула расчета выглядит так:

=СУММ(B2:D4)

Вы также можете применить ее и для нескольких областей, которые не пересекаются между собой и находятся в разных местах вашей электронной таблицы.

В формуле последовательно перечисляем несколько диапазонов:

=СУММ(B2:D4;B8:D10)

Естественно, их может быть не два, а гораздо больше: до 255 штук.

Как вычислить сумму каждой N-ой строки.

В таблице расположены повторяющиеся с определенной периодичностью показатели — продажи по отделам. Необходимо рассчитать общую выручку по каждому из них. Сложность в том, что интересующие нас показатели находятся не рядом, а чередуются. Предположим, мы анализируем сведения о продажах трех отделов помесячно. Необходимо определить продажи по каждому отделу.

Иначе говоря, нужно, двигаясь вниз, взять каждую третью строчку.

Это можно сделать двумя способами.

Первый – самый простой, «в лоб». Складываем все цифры нужного отдела обычной математической операцией сложения. Выглядит просто, но представьте, если у вас статистика, предположим, за 3 года? Придется обработать 36 чисел…

Второй способ – для более «продвинутых», но зато универсальный.

Записываем

=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(C2:C16)+1;3)=0;C2:C16))

И затем нажимаем комбинацию клавиш CTRL+SHIFT+ENTER, поскольку используется формула массива. Excel сам добавит к фигурные скобки слева и справа.

Как это работает? Нам нужна 1-я, 3-я, 6-я и т.д. позиции. При помощи функции СТРОКА() мы вычисляем номер текущей позиции. И если остаток от деления на 3 будет равен нулю, то значение будет учтено в расчете. В противном случае – нет.

Для такого счетчика мы будем использовать номера строк. Но наше первое число находится во второй строке рабочего листа Эксель. Поскольку надо начинать с первой позиции и потом брать каждую третью, а начинается диапазон со 2-й строчки, то к порядковому номеру её добавляем 1. Тогда у нас счетчик начнет считать с цифры 3. Для этого и служит выражение СТРОКА(C2:C16)+1. Получим 2+1=3, остаток от деления на 3 равен нулю. Так мы возьмем 1-ю, 3-ю, 6-ю и т.д. позиции.

Формула массива означает, что Excel должен последовательно перебрать все ячейки диапазона – начиная с C2 до C16, и с каждой из них произвести описанные выше операции.

Когда будем находить продажи по Отделу 2, то изменим выражение:

=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(C2:C16);3)=0;C2:C16))

Ничего не добавляем, поскольку первое подходящее значение как раз и находится в 3-й позиции.

Аналогично для Отдела 3

=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(C2:C16)-1;3)=0;C2:C16))

Вместо добавления 1 теперь вычитаем 1, чтобы отсчет вновь начался с 3. Теперь брать будем каждую третью позицию, начиная с 4-й.

Ну и, конечно, не забываем нажимать CTRL+SHIFT+ENTER.

Примечание. Точно таким же образом можно суммировать и каждый N-й столбец в таблице. Только вместо функции СТРОКА() нужно будет использовать СТОЛБЕЦ().

Сумма каждых N строк.

В таблице Excel записана ежедневная выручка магазина за длительный период времени. Необходимо рассчитать еженедельную выручку за каждую семидневку.

Используем то, что СУММ() может складывать значения не только в диапазоне данных, но и в массиве. Такой массив значений ей может предоставить функция СМЕЩ.

Напомним, что здесь нужно указать несколько аргументов:

1.       Начальную точку. Обратите внимание, что С2 мы ввели как абсолютную ссылку.

2.       Сколько шагов вниз сделать

3.       Сколько шагов вправо сделать. После этого попадаем в начальную (левую верхнюю) точку массива.

4.       Сколько значений взять, вновь двигаясь вниз.

5. Сколько колонок будет в массиве. Попадаем в конечную (правую нижнюю) точку массива значений.

Итак, формула для 1-й недели:

=СУММ(СМЕЩ($C$2;(СТРОКА()-2)*5;0;5;1))

В данном случае СТРОКА() – это как бы наш счетчик недель. Отсчет нужно начинать с 0, чтобы действия начать прямо с ячейки C2, никуда вниз не перемещаясь. Для этого используем СТРОКА()-2. Поскольку сама формула находится в ячейке F2, получаем в результате 0. Началом отсчета будет С2, а конец его – на 5 значений ниже в той же колонке.

СУММ просто сложит предложенные ей пять значений.

Для 2-й недели в F3 формулу просто копируем. СТРОКА()-2 даст здесь результат 1, поэтому начало массива будет 1*5=5, то есть на 5 значений вниз в ячейке C7 и до С11. И так далее.

Как найти сумму наибольших (наименьших) значений. 

Задача: Суммировать 3 максимальных или 3 минимальных значения.

Функция НАИБОЛЬШИЙ возвращает самое большое значение из перечня данных. Хитрость в том, что второй ее аргумент показывает, какое именно значение нужно вернуть: 1- самое большое, 2 – второе по величине и т.д. А если указать {1;2;3} – значит, нужны три самых больших. Но при этом не забывайте применять формулу массива и завершать комбинацией клавиш CTRL+SHIFT+ENTER.

=СУММ(НАИБОЛЬШИЙ(B2:D13;{1;2;3}))

Аналогично обстоит дело и с самыми маленькими значениями:

=СУММ(НАИМЕНЬШИЙ(B2:D13;{1;2;3}))

3-D сумма, или работаем с несколькими листами рабочей книги Excel.

Чтобы подсчитать цифры из одинаковой формы диапазона на нескольких листах, вы можете записывать координаты данных специальным синтаксисом, называемым «3d-ссылка».

Предположим, на каждом отдельном листе вашей рабочей книги имеется таблица с данными за неделю. Вам нужно свести все это в единое целое и получить свод за месяц. Для этого будем ссылаться на четыре листа.

Посмотрите на этом небольшом видео, как применяются 3-D формулы.

Как видите, у нас имеется 4 одинаковых таблицы. Стандартный метод нахождения выручки за месяц –

=СУММ(неделя1!B2:B8;неделя2!B2:B8;неделя3!B2:B8;неделя4!B2:B8)

В качестве аргументов перечисляем диапазоны данных.

А вот 3D-метод:

=СУММ(неделя1:неделя4!B2:B8)

Мы указываем программе, что нужно произвести вычисления с ячейками B2:B8, находящимися на листах неделя1, неделя2, неделя3, неделя4. Здесь номер листа последовательно увеличивается на 1.

Важное замечание. Вы можете пользоваться 3D-ссылками и в других случаях. К примеру, выражение

=СРЗНАЧ(неделя1!B2:B8;неделя2!B2:B8;неделя3!B2:B8;неделя4!B2:B8)

найдет среднее значение однодневной выручки за месяц.

Поиск нужного столбца и расчет его суммы.

Имеются сведения о продаже товаров, для каждого из них выделен отдельная колонка. Необходимо рассчитать продажи по выбранному товару. Иначе говоря, нам в Экселе нужно рассчитать сумму столбца, но сначала нужно всего лишь найти этот нужный нам столбец среди других аналогичных.

Для поиска и выбора конкретного товара используем весьма популярную комбинацию функций ИНДЕКС+ПОИСКПОЗ.

Расчет суммы в G3 выполним так:

=СУММ(ИНДЕКС(B2:D21;0;ПОИСКПОЗ(F3;B1:D1;0)))

Итак, комбинация ИНДЕКС+ПОИСКПОЗ должны возвратить для дальнейших расчетов набор чисел в виде вертикального массива, который и будет потом просуммирован.

Опишем это подробнее.

ПОИСКПОЗ находит в шапке наименований таблицы B1:D1 нужный продукт (бананы) и возвращает его порядковый номер (иначе говоря, 2).

Затем ИНДЕКС выбирает из массива значений B2:D21 соответствующий номер столбца (второй). Будет возвращен весь столбик данных с соответствующим номером, поскольку номер строки (первый параметр функции) указан равным 0. На нашем рисунке это будет С2:С21. Остается только подсчитать все значения в этой колонке.

В данном случае, чтобы избежать ошибок при записи названия товара, мы рекомендовали бы использовать выпадающий список в F3, а значения для наполнения его брать из B1:D1.

5 способов создать выпадающий список в Excel — рекомендуем ознакомиться.

Сумма столбцов из нескольких таблиц.

Как в Экселе посчитать сумму столбца, если таких столбцов несколько, да и сами они находятся в нескольких разных таблицах?

Для получения итогов сразу по нескольким таблицам также используем функцию СУММ и структурированные ссылки. Такие ссылки появляются при создании в Excel «умной» таблицы.

При создании её Excel назначает имя самой таблице и каждому заголовку колонки в ней. Эти имена затем можно использовать в выражениях: они могут отображаться в виде подсказок в строке ввода.

В нашем случае это выглядит так:

Прямая ссылка Структурированная ссылка (Имя таблицы и столбца)
B2:B21 Таблица2[Сумма]

Для создания «умной» таблицы выделим диапазон A1:B21 и на ленте «Главная» выбираем «Форматировать как таблицу».

Приятным бонусом здесь является то, что «умная» таблица сама изменяет свои размеры при добавлении в нее данных (или же их удалении), ссылки на нее корректировать не нужно.

Также в нашем случае не принципиально, где именно располагаются в вашем файле Excel эти данные. Даже не важно, что они находятся на разных листах – программа все равно найдет их по имени.

Помимо этого, если используемые вами таблицы содержат строчку итогов, то нашу формулу перепишем так:

=СУММ(Таблица2[#Итоги];Таблица3[#Итоги])

И если будут внесены какие-то изменения или добавлены цифры, то все пересчитается автоматически.

Примечание: итоговая строчка в таблице должна быть включена. Если вы отключите её, то выражение вернет ошибку #ССЫЛКА.

Еще одно важное замечание. Чуть выше мы с вами говорили, что функция СУММ должна сложить сумму всех значений в строке или столбце – даже если они скрыты или же фильтр значений не позволяет их увидеть.

В нашем случае, если в таблице включена строка итогов, вы с ее помощью получите сумму только видимых ячеек.

Как вы видите на этом рисунке, если отфильтровать часть значений, то общие продажи, рассчитанные вторым способом, изменятся.

В то время как если просто складывать ячейки и не использовать итоговую строку «умной» таблицы, то фильтр и скрытие отдельных позиций никак не меняет результат вычислений.

Надеемся, что теперь суммировать области данных или же отдельные ячейки вам будет гораздо проще.

Также рекомендуем:

Как посчитать количество пустых и непустых ячеек в ExcelКак сравнить два столбца на совпадения и различияФормула суммы в Excel — несколько полезных советов и примеровФункция СЧЁТЕСЛИМН в Excel с несколькими условиями — объясняем на примерах.СЧЕТЕСЛИ в Excel — примеры функции с одним и несколькими условиямиФункция СУММЕСЛИМН — как суммировать ячейки в Excel, когда много условий?7 примеров использования формулы СУММЕСЛИ в Excel с несколькими условиямиКак проверить правильность ввода данных в Excel?

Считаем сумму в столбце в Экселе

Посчитать сумму тех или иных значений в столбцах электронной таблицы Excel можно как вручную, так и автоматически, воспользовавшись базовым инструментарием программы. Кроме того, имеется возможность обычного просмотра итогового значения без его записи в ячейку. Как раз с последнего, наиболее простого мы и начнем.

Способ 1: Просмотр общей суммы

Если вам нужно просто увидеть общее значение по столбцу, в ячейках которого содержаться определенные сведения, при этом постоянно держать эту сумму перед глазами и создавать для ее вычисления формулу не требуется, выполните следующее:

  1. С помощью мышки выделите диапазон ячеек в столбце, сумму значений в котором требуется посчитать. В нашем примере это будут ячейки с 3 по 9 столбца G.
  2. Взгляните на строку состояния (нижняя панель программы) – там будет указана искомая сумма. Отображаться это значение будет исключительно до тех пор, пока выделен диапазон ячеек.
  3. Дополнительно. Такое суммирование работает, даже если в столбце есть пустые ячейки. Более того, аналогичным образом можно посчитать сумму всех значений в ячейках сразу из нескольких столбцов – достаточно просто выделить необходимый диапазон и посмотреть на строку состояния. Подробнее о том, как это работает, расскажем в третьем способе данной статьи, но уже на примере шаблонной формулы.

Примечание: Слева от суммы указано количество выделенных ячеек, а также среднее значение для всех указанных в них чисел.

</ol>

Способ 2: Автосумма

Очевидно, что значительно чаще сумму значений в столбце требуется держать перед глазами, видеть ее в отдельной ячейке и, конечно же, отслеживать изменения, если таковые вносятся в таблицу. Оптимальным решением в таком случае будет автоматическое суммирование, выполняемое с помощью простой формулы.

  1. Нажмите левой кнопкой мышки (ЛКМ) по пустой ячейке, расположенной под теми, сумму которых требуется посчитать.
  2. Кликните ЛКМ по кнопке «Сумма», расположенной в блоке инструментов «Редактирование» (вкладка «Главная»). Вместо этого можно воспользоваться комбинацией клавиш «ALT» + «=».
  3. Убедитесь, что в формуле, которая появилась в выделенной ячейке и строке формул, указан адрес первой и последней из тех, которые необходимо суммировать, и нажмите «ENTER». Вы сразу же увидите сумму чисел во всем выделенном диапазоне.

Примечание: Любое изменение в ячейках из выделенного диапазона моментально будет отражаться на итоговой формуле, то есть результат в ней тоже будет меняться.

</ol>

Бывает так, что сумму нужно вывести не в ту ячейку, которая находится под суммируемыми, а в какую-нибудь другую, возможно, расположенную совсем в другом столбце таблицы. В таком случае действовать необходимо следующим образом:

  1. Выделите кликом ячейку, в которой будет вычисляться сумма значений.
  2. Нажмите по кнопке «Сумма» или воспользуйтесь горячим клавишам, предназначенным для ввода этой же формулы.
  3. С помощью мышки выделите диапазон ячеек, которые требуется просуммировать, и нажмите «ENTER».

Совет: Выделить диапазон ячеек можно и немного иным способом – кликните ЛКМ по первой из них, затем зажмите клавишу «SHIFT» и кликните по последней.

Практически точно так же можно суммировать значения сразу из нескольких столбцов или отдельных ячеек, даже если в диапазоне будут пустые ячейки, но обо всем этом далее.</ol>

Способ 3: Автосумма нескольких столбцов

Бывает так, что требуется посчитать сумму не в одном, а сразу в нескольких столбцах электронной таблицы Эксель. Делается это практически так же, как и в предыдущем способе, но с одним небольшим нюансом.

  1. Щелкните ЛКМ по той ячейке, в которую планируете выводить сумму всех значений.
  2. Нажмите по кнопке «Сумма» на панели инструментов или воспользуйтесь предназначенной для ввода этой формулы комбинацией клавиш.
  3. Первый столбец (над формулой) уже будет выделен. Поэтому зажмите клавишу «CTRL» на клавиатуре и выделите следующий диапазон ячеек, который тоже должен входить в рассчитываемую сумму.

Примечание: Если столбцы, которые требуется посчитать, идут подряд, выделять их можно все вместе.

Далее, аналогичным образом, если это еще потребуется, зажимая клавишу «CTRL», выделите ячейки из других столбцов, содержимое которых тоже должно входить в итоговую сумму. Нажмите «ENTER» для подсчета, после чего в предназначенной для формулы ячейке и строке на панели инструментов появится итоговое вычисление.</li>

Несложно догадаться, что аналогичным образом можно посчитать сумму значений в отдельных ячейках, состоящих как в разных столбцах, так и в пределах одного.

Для этого нужно просто выделить кликом ячейку для формулы, нажать по кнопке «Сумма» или на горячие клавиши, выделить первый диапазон ячеек, а затем, зажимая клавишу «CTRL», выделить все остальные «участки» таблицы. Сделав это, просто нажмите «ENTER» для отображения результата. Как и в предыдущем способе, формула суммы может быть записана в любую из свободных ячеек таблицы, а не только в ту, которая находится под суммируемыми.</ol>

Способ 4: Суммирование вручную

Как и любая формула в Microsoft Excel, «Сумма» имеет свой синтаксис, а потому она может быть прописана вручную. Зачем это нужно? Хотя бы за тем, что таким образом вы точно сможете избежать случайных ошибок при выделении суммируемого диапазона и указании входящих в него ячеек. Более того, даже если вы ошибетесь на каком-то из шагов, исправить это будет так же просто, как банальную опечатку в тексте, а значит, не потребуется проделывать всю работу с нуля, как это иногда приходится делать.

Помимо прочего, самостоятельный ввод формулы позволяет разместить ее не только в любом месте таблицы, но и на любом из листов конкретного электронного документа. Стоит ли говорить о том, что таким образом можно просуммировать не только столбцы и/или их диапазоны, но и просто отдельные ячейки или группы таковых, исключая при этом те, которые не должны быть учтены?

Формула суммы имеет следующий синтаксис:

=СУММ(суммируемые ячейки или диапазон таковых) То есть все то, что должно быть суммировано, записывается в скобки. Значения, указываемые внутри скобок, должны выглядеть следующим образом:

  • Для диапазона: А1:A10 – это сумма 10 первых ячеек в столбце A.
  • Для отдельных ячеек: A2;A5;A7;A10 – сумма ячеек №2, 5, 7,10 столбца A.
  • Смешанное значение (диапазоны и отдельные ячейки): A1;A3:A5;A7;A9:15 – сумма ячеек №1, 3-5, 7, 9-15. При этом важно понимать, что между диапазонами и единичными ячейками не должно стоять никакого дополнительного символа-разделителя.

А теперь перейдем непосредственно к ручному суммированию значений в столбце/столбцах электронной таблицы Эксель.

  1. Выделите нажатием ЛКМ ту ячейку, которая будет содержать итоговую формулу.
  2. Введите в нее следующее: =СУММ( после чего начните поочередно вводить в строке формул адреса суммируемых диапазонов и/или отдельных ячеек, не забывая о разделителях («:» — для диапазона, «;» — для единичных ячеек, вводить без кавычек), то есть делайте все по тому алгоритму, суть которого мы выше подробно описали.
  3. Указав все те элементы, которые требуется просуммировать и убедившись, что вы ничего не пропустили (можно сориентироваться не только по адресам в строке формул, но и по подсветке выделенных ячеек), закройте скобку и нажмите «ENTER» для подсчета.

    Примечание: Если вы заметили ошибку в итоговой формуле (например, туда вошла лишняя ячейка или какая-то была пропущена), просто вручную введите правильное обозначение (или удалите лишнее) в строке формул. Аналогичным образом, если и когда это потребуется, можно поступить и с символами-разделителями в виде «;» и «:».

    Как вы, наверное, уже могли догадаться, вместо ручного ввода адресов ячеек и их диапазонов можно просто выделять необходимые элементы с помощью мышки. Главное, не забывать при этом удерживать клавишу «CTRL», когда вы переходите от выделения одного элемента к другому. Самостоятельный, ручной подсчет суммы в столбце/столбцах и/или отдельных ячейках таблицы – задача не самая удобная и быстрая в реализации. Но, как мы уже сказали выше, такой подход предоставляет куда более широкие возможности для взаимодействия со значениями и позволяет моментально исправлять случайные ошибки. А вот то, делать ли это полностью вручную, вводя с клавиатуры в формулу каждую переменную, или использовать для этого мышку и горячие клавиши – решать только вам.

Заключение

Даже такая, казалось бы, простая задача, как подсчет суммы в столбце, решается в табличном процессоре Microsoft Excel сразу несколькими способами, и каждый из них найдет свое применение в той или иной ситуации. Мы рады, что смогли помочь Вам в решении проблемы.Опишите, что у вас не получилось. Наши специалисты постараются ответить максимально быстро.

Помогла ли вам эта статья?

Табличный процессор Excel – отличное решение для обработки разного рода данных. С его помощью можно быстро производить расчеты с регулярно меняющимися данными. Однако Excel достаточно сложная программа и поэтому многие пользователи даже не начинают ее изучать.

Если вам необходимо посчитать сумму столбца в Excel, то это делается достаточно просто. Для этого вам понадобится кнопка «Авто сумма». Она находится на вкладке «Главная» (справа, в самом конце вкладки).

Также кнопка «Авто сумма» дублируется на вкладе «Формулы».

Для того чтобы посчитать сумму столбца, выделите этот столбец с помощью мышки и нажмите на кнопку «Авто сумма».

После выделения столбца с данными и нажатия на кнопку «Авто сумма» Excel автоматически сгенерирует формулу для подсчета суммы столбца и вставит ее в ячейку сразу под столбцом с данными.

Если такое расположение суммы столбца вам не подходит, то вы можете сами указать, где хотите расположить сумму. Для этого нужно выделить подходящую для суммы ячейку, нажать на кнопку «Автосумма», а потом выделить мышкой столбец с данными и нажать на клавишу Enter на клавиатуре.

В этом случае сумма столбца будет расположена не под столбцом с данными, а в выбранной вами ячейке таблицы.

Если вам нужно посчитать сумму определенных ячеек в Excel, то это также можно сделать при помощи функции «Авто сумма». Для этого нужно выделить мышкой ячейку таблицы, в которую вы хотите поместить сумму, нажать на кнопку «Авто сумма» и выбрать нужные ячейки удерживая зажатой клавишу CTRL на клавиатуре. После того, как нужные ячейки выбраны, нажмите на клавишу Enter на клавиатуре, и в выбранной вами ячейке таблицы будет помещена сумма.

Кроме этого, вы можете вписать формулу для подсчета суммы определенных ячеек вручную. Для этого установите курсор там, где должна находится сумма, а потом введите формулу в формате: =СУММ(D3; D5; D7). Где вместо D3, D5 и D7 – адреса нужных вам ячеек. Обратите внимание, адреса ячеек вводятся через запятую, после последней ячейки запятая не нужна. После ввода формулы нажмите клавишу Eneter и в выбранной вами ячейке появится сумма.

Если формулу нужно отредактировать, например, вам нужно изменить адреса ячеек, то для этого нужно выделить ячейку с суммой и изменить формулу в строке для формул.

Если вам нужно быстро посмотреть какая сумма получится если сложить определенные ячейки, и при этом вам не нужно выводить значение суммы в таблицу, то вы можете просто выделить ячейки и посмотреть вниз окна Excel. Там вы сможете найти информацию о сумме выделенных ячеек.

Также там будет указано количество выделенных ячеек и их среднее значение.

Посмотрите также:

2552020.02.2013 Скачать пример

Постановка задачи

Имеем таблицу по продажам, например, следующего вида:

Задача: просуммировать все заказы, которые менеджер Григорьев реализовал для магазина «Копейка».

Способ 1. Функция СУММЕСЛИ, когда одно условие

Если бы в нашей задаче было только одно условие (все заказы Петрова или все заказы в «Копейку», например), то задача решалась бы достаточно легко при помощи встроенной функции Excel СУММЕСЛИ (SUMIF) из категории Математические (Math&Trig). Выделяем пустую ячейку для результата, жмем кнопку fx в строке формул, находим функцию СУММЕСЛИ в списке:

Жмем ОК и вводим ее аргументы:

  • Диапазон — это те ячейки, которые мы проверяем на выполнение Критерия. В нашем случае — это диапазон с фамилиями менеджеров продаж.
  • Критерий — это то, что мы ищем в предыдущем указанном диапазоне. Разрешается использовать символы * (звездочка) и  ? (вопросительный знак) как маски или символы подстановки. Звездочка подменяет собой любое количество любых символов, вопросительный знак — один любой символ. Так, например, чтобы найти все продажи у менеджеров с фамилией из пяти букв, можно использовать критерий ?????. А чтобы найти все продажи менеджеров, у которых фамилия начинается на букву «П», а заканчивается на «В» — критерий П*В. Строчные и прописные буквы не различаются.
  • Диапазон_суммирования — это те ячейки, значения которых мы хотим сложить, т.е. нашем случае — стоимости заказов.

Способ 2. Функция СУММЕСЛИМН, когда условий много

Если условий больше одного (например, нужно найти сумму всех заказов Григорьева для «Копейки»), то функция СУММЕСЛИ (SUMIF) не поможет, т.к. не умеет проверять больше одного критерия. Поэтому начиная с версии Excel 2007 в набор функций была добавлена функция СУММЕСЛИМН (SUMIFS) — в ней количество условий проверки увеличено аж до 127! Функция находится в той же категории Математические и работает похожим образом, но имеет больше аргументов:

При помощи полосы прокрутки в правой части окна можно задать и третью пару (Диапазон_условия3Условие3), и четвертую, и т.д. — при необходимости.

Если же у вас пока еще старая версия Excel 2003, но задачу с несколькими условиями решить нужно, то придется извращаться — см. следующие способы.

Способ 3. Столбец-индикатор

Добавим к нашей таблице еще один столбец, который будет служить своеобразным индикатором: если заказ был в «Копейку» и от Григорьева, то в ячейке этого столбца будет значение 1, иначе — 0. Формула, которую надо ввести в этот столбец очень простая:

=(A2=»Копейка»)*(B2=»Григорьев»)

Логические равенства в скобках дают значения ИСТИНА или ЛОЖЬ, что для Excel равносильно 1 и 0. Таким образом, поскольку мы перемножаем эти выражения, единица в конечном счете получится только если оба условия выполняются. Теперь стоимости продаж осталось умножить на значения получившегося столбца и просуммировать отобранное в зеленой ячейке:

Способ 4. Волшебная формула массива

Если вы раньше не сталкивались с такой замечательной возможностью Excel как формулы массива, то советую почитать предварительно про них много хорошего здесь. Ну, а в нашем случае задача решается одной формулой:

=СУММ((A2:A26=»Копейка»)*(B2:B26=»Григорьев»)*D2:D26)

После ввода этой формулы необходимо нажать не Enter, как обычно, а Ctrl + Shift + Enter — тогда Excel воспримет ее как формулу массива и сам добавит фигурные скобки. Вводить скобки с клавиатуры не надо. Легко сообразить, что этот способ (как и предыдущий) легко масштабируется на три, четыре и т.д. условий без каких-либо ограничений.

Способ 4. Функция баз данных БДСУММ

В категории Базы данных (Database) можно найти функцию БДСУММ (DSUM), которая тоже способна решить нашу задачу. Нюанс состоит в том, что для работы этой функции необходимо создать на листе специальный диапазон критериев — ячейки, содержащие условия отбора — и указать затем этот диапазон функции как аргумент:

=БДСУММ(A1:D26;D1;F1:G2)

В этом руководстве по Excel объясняется, как использовать функцию СУММ(SUM) в Excel, с синтаксисом и примерами.

Содержание

Описание

Функция СУММ возвращает сумму предоставленных значений. Эти значения могут быть числами, ссылками на ячейки, диапазонами, массивами и константами в любой комбинации. SUM может обрабатывать до 255 отдельных аргументов.

Функция СУММ — это встроенная функция Excel, относящаяся к категории математических / триггерных функций. Как функцию рабочего листа, функцию СУММ можно ввести как часть формулы в ячейку рабочего листа.

Функция СУММ на Русском Функция СУММна Английском
СУММ SUM

Синтаксис

Синтаксис функции СУММ=СУММ([Число1], [Число2] ,…)

Первый аргумент является обязательным, другие числа необязательны, и вы можете ввести до 255 чисел в одной формуле.

В Формуле суммы Excel каждый аргумент может быть положительным или отрицательным числовым значением, диапазоном или ссылкой на ячейку. Например:

=СУММ(A1:A100)=СУММ(A1;A2;A5)=СУММ(1;5;-2)

Пример функции СУММ

Давайте посмотрим на несколько примеров функции СУММ в Excel и узнаем, как использовать функцию СУММ в качестве функции рабочего листа в Microsoft Excel:

На изображении выше у нас в столбце А расположены значения, допустим вы хотите сложить значения 2 и 3 строки для этого пишем в ячейке которой вы хотите увидеть результат =СУММ(A2;A3).Если вы хотите суммировать весь диапазон значений то указывайте его через двоеточие, например в нашем случае это будет =СУММ(A2:A6).

Для того чтобы не писать какие ячейки вы хотите суммировать, вы набираете =СУММ( или выбираете эту функцию в окне «Вставка функции» найти его можно на панели меню выбираете «Формулы»->»Вставка функции»

И щелчком мыши с зажатой клавишей CTRL выбираете ячейки которые хотите суммировать, для выбора диапазона CTRL можно не зажимать.

Cумма столбца в эксел

Если вы хотите посмотреть сумму всего столбца и при этом не выводить ее в таблице, то вам нужно щелкнуть по заголовку столбца левой кнопкой мыши и внизу будет вся нужная вам информация, на изображении ниже показано где смотреть.

Таким же способом можно подсчитать сумму нескольких столбцов, просто выделив нужные вам.

Если столбец, который вы хотите суммировать, имеет переменное количество строк (т. е. Новые ячейки могут быть добавлены, а существующие могут быть удалены в любое время), вы можете просуммировать весь столбец, указав ссылку на столбец, без указания нижней или верхней границы , Например: =SUM(B:B), но в этом случае вы не должны помещать формулу «Сумма столбца» в столбец, который вы хотите суммировать потому что это создаст циклическую ссылку на ячейку, и ваша формула СУММ вернет 0.

Автосумма столбца

Если в конце столбца вам необходимо вывести сумму этого столбца то вам необходимо выполнить следующие шаги:

  1. Выделить ячейку в которой будет сумма строк выше
  2. Выбираем в меню «Главная» значек Сумма
  1. После выбора программа выделяет нужный диапазон, проверяем все ли правильно и нажимаем Enter.

Более быстрый способ выполнить автосумму в Excel — использовать 

Alt + =, 

Просто удерживайте клавишу Alt, нажмите клавишу со знаком равенства, а затем нажмите Enter, чтобы завершить автоматически вставленную формулу суммы.

Сумма строки эксел

Чтобы суммировать всю строку с неопределенным числом столбцов, укажите ссылку на всю строку в формуле Excel СУММ, например:

=СУММ(2:2)

Помните, что вы не должны вводить эту формулу «Сумма строки» в любой ячейке той же строки, чтобы избежать создания циклической ссылки, поскольку это приведет к неправильному вычислению, если таковое имеется:

Используемые источники:

  • https://mister-office.ru/funktsii-excel/sum-function-excel.html
  • https://lumpics.ru/how-to-calculate-sum-of-column-in-excel/
  • https://comp-security.net/как-посчитать-сумму-в-excel/
  • https://www.planetaexcel.ru/techniques/2/167/
  • https://gospodaretsva.com/kak-poschitat-summu-v-eksel.html

Оцените статью
Рейтинг автора
5
Материал подготовил
Илья Коршунов
Наш эксперт
Написано статей
134
Добавить комментарий