Самоучитель Excel с примерами для пользователей среднего уровня

Excel, безусловно, одна из самых необходимых программ. Она сделала жизнь множества пользователей легче. Excel позволяет автоматизировать даже самые сложные вычисления, и в этом заключается основное преимущество этой программы.

Как правило, стандартный пользователь применяет лишь ограниченный набор функций, в то время как существует множество формул, позволяющих реализовывать те же задачи, но значительно быстрее.

Это может быть полезно, если постоянно приходится выполнять множество однотипных действий, требующих большого количества операций.

Стало интересно? Тогда добро пожаловать в обзор самых полезных 15 формул Excel.

Немного терминологии

Перед тем, как непосредственно начать обзор функций, нужно разобраться в том, что же это такое. Под этим понятием подразумевается заложенная разработчиками формула, по которой осуществляются вычисления и на выходе получается определенный результат. 

Каждая функция имеет две основные части: имя и аргумент. Формула может состоять из одной функции или нескольких. Чтобы ее начать писать, нужно кликнуть дважды по требуемой ячейке и написать знак «равно».

Следующая составная часть функции – это имя. Собственно, им и является название формулы, которое поможет Excel понять, что хочет пользователь. Вслед за ним в скобках приводятся аргументы. Это параметры функции, учитываемые для выполнения определенных операций. Бывает несколько типов аргументов: числовые, текстовые, логические. Также вместо них нередко используются ссылки на ячейки или определенный диапазон. Каждый аргумент отделяется от другого с помощью точки с запятой.

Синтаксис – одно из главных понятий, характеризующих функцию. Под этим термином подразумевается шаблон для вставки определенных значений с целью обеспечить работоспособность функции.

А теперь давайте все это проверим на практике.

Формула 1: ВПР

Эта функция дает возможность найти требуемую информацию в таблице, а возвращенный результат вывести в определенную ячейку. Аббревиатура, обозначающая название функции, расшифровывается, как «вертикальный просмотр».

Синтаксис

Это довольно сложная формула, имеющая 4 аргумента, а ее использование имеет множество особенностей.

Синтаксис такой:

=ВПР(искомое_значение;таблица;номер_столбца;[интервальный_просмотр])

Давайте более подробно рассмотрим все аргументы:

  1. Значение, которое ищется.
  2. Таблица. Необходимо, чтобы было искомое значение, находящееся в первой колонке, а также значение, которое возвращается. Последнее располагается где-угодно. Пользователь может самостоятельно определиться, куда вставлять результат формулы. 
  3. Номер столбца.
  4. Интервальный просмотр. Если в этом нет необходимости, то можно не приводить значение этого аргумента. Оно являет собой логическое выражение, обозначающее степень точности совпадения, которое должно быть обнаружено функцией. Если указан параметр «Истина», то тогда Excel будет искать самое близкое значение к указанному в качестве искомого. Если же указан параметр «Ложь», то функция будет искать только те значения, которые находятся в первой колонке.

На этом скриншоте мы пробуем с помощью формулы понять, сколько просмотров было осуществлено по запросу «купить планшет».

Формула 2: Если

Эта функция необходима, если пользователь хочет задать определенное условие, при котором должен осуществляться расчет или выводиться конкретное значение. Она может принимать два варианта: истинное и ложное.

Синтаксис

В формулу этой функции входит три основных аргумента, и она выглядит так:

=ЕСЛИ(логическое_выражение;«значение_если_истина»;«значение_если_ложь»).

Здесь под логическим выражением подразумевается непосредственно описывающая критерий формула. С ее помощью будут проверяться данные на предмет соответствия определенному условию. Соответственно, аргумент «значение если ложь» предназначен для той же задачи, с тем лишь отличием, что оно зеркально противоположное по смыслу. Простыми словами, если условие не подтвердилось, то программа осуществляет определенные действия.

Есть еще один вариант, как можно применять функцию ЕСЛИ – вложенные функции. Здесь может быть намного больше условий, вплоть до 64. Пример рассуждения, соответствующего формуле, приведенной на скриншоте, такой. Если ячейка А2 равна двум, то нужно вывести значение «Да». Если же она имеет другое значение, то необходимо проверить, равна ли ячейка D2 двум. Если да, то нужно выдать значение «нет», если и здесь условие оказывается ложным, то формула должна вернуть значение «возможно».1.jpg

Не рекомендуется пользоваться вложенными функциями слишком часто, поскольку их использовать довольно тяжело, возможны ошибки. И потребуется немало времени, чтобы их исправить. 

Функция ЕСЛИ может применяться и с целью понять, пустая ли определенная ячейка. Чтобы добиться этой цели, необходимо использовать еще одну функцию – ЕПУСТО.

Тут синтаксис следующий:

=ЕСЛИ(ЕПУСТО(номер ячейки);«Пустая»;«Не пустая»).3.jpg

Кроме этого, есть возможность применять вместо функции ЕПУСТО применять стандартную формулу, но указать, что при условии отсутствия никаких значений в ячейке.

ЕСЛИ – это одна из наиболее часто встречаемых функций, которая очень легко используется и она дает возможность понять, насколько истинны те или иные значения, получить результаты по разным критериям, а также определить, является ли определенная ячейка пустой.

Эта функция является фундаментом для некоторых других формул. Некоторые из них мы сейчас проанализируем более детально.

Формула 3: СУММЕСЛИ

Функция СУММЕСЛИ позволяет суммировать данные, при условии их соответствия определенным критериям.

Синтаксис

Эта функция, аналогично предыдущей, имеет три аргумента. Чтобы ее использовать, необходимо написать такую формулу, подставив необходимые значения в соответствующих местах.

=СУММЕСЛИ(диапазон;условие;[диапазон_суммирования])

Давайте более подробно поймем, что каждый из аргументов собой являет:

  1. Условие. Этот аргумент позволяет передать в функцию ячейки, которые в дальнейшем подлежат суммированию.
  2. Диапазон суммирования. Этот аргумент не является обязательным, и он дает возможность задать ячейки, которые необходимо суммировать, если условие оказывается ложным.

Так, в данной ситуации Excel суммировал данные о тех запросах, где количество переходов превышает 100000.

Формула 4: СУММЕСЛИМН

Если же условий несколько, то используется родственная функция СУММЕСЛИМН.

Синтаксис

Формула этой функции выглядит так:

=СУММЕСЛИМН(диапазон_суммирования; диапазон_условия1; условие1; [диапазон_условия2; условие2]; …)

Обязательными являются второй и третий аргументы, а именно «Диапазон условия 1» и «условие 1».

Формула 5: СЧЕТЕСЛИ и СЧЕТЕСЛИМН

Эта функция пытается определить количество непустых ячеек, которые подходят под заданные условия в рамках диапазона, введенного пользователем.

Синтаксис

Чтобы ввести эту функцию, необходимо указать следующую формулу:

=СЧЕТЕСЛИ(диапазон;критерий)

Что означают приведенные аргументы?

  1. Диапазон – это совокупность ячеек, среди которой должен осуществляться подсчет.
  2. Критерий – условие, учитываемое при выборе ячеек.

Например, этом примере программа посчитала число ключевых запросов, где количество переходов в поисковых системах превышает сто тысяч. В итоге, формула вернула число 3, что означает, наличие трех таких ключевиков.

Если говорить о родственной функции СЧЕТЕСЛИМН, то она, аналогично предыдущему примеру, предоставляет возможность использовать сразу несколько критериев. Ее формула следующая:

=СЧЁТЕСЛИМН(диапазон_условия1;условие1;[диапазон_условия2;условие2];…)

И аналогично предыдущему случаю «Диапазон условия 1» и «условие 1» – это обязательные аргументы, другие же можно не использовать, если нет такой необходимости. Максимально функция предусматривает возможность применять до 127 диапазонов вместе с условиями.

Формула 6: ЕСЛИОШИБКА

Эта функция возвращает заданное пользователем значение, если в процессе вычисления по формуле обнаруживается ошибка. Если же получившееся значение корректное, она оставляет его.

Синтаксис

У этой функции два аргумента. Синтаксис следующий:

=ЕСЛИОШИБКА(значение;значение_если_ошибка)

Описание аргументов:

  1. Значение – непосредственно формула, проверяемая на предмет багов.
  2. Значение если ошибка – результат, появляющийся после того, как ошибка будет обнаружена.

Если говорить о примерах, то данная формула покажет в случае невозможности осуществления деления текст «Ошибка при вычислении».

Формула 7: ЛЕВСИМВ

Эта функция дает возможность выделить требуемое количество символов слева строки.

Ее синтаксис следующий:

=ЛЕВСИМВ(текст;[число_знаков])

Возможные аргументы:

  1. Текст – строка, из какой требуется достать определенный фрагмент.
  2. Число знаков – непосредственно количество знаков, которые нужно извлекать.

Так, в данном примере видно, как эта функция используется с целью посмотреть, какой будет внешний вид у тайтлов к страницам сайтов. То есть, поместится ли строка в определенное количество знаков или нет.

Формула 8: ПСТР

Эта функция дает возможность достать требуемое количество знаков с текста, начиная определенным символом по счету.

Ее синтаксис следующий:

=ПСТР(текст;начальная_позиция;число_знаков).

Расшифровка аргументов:

  1. Текст – это строка, в которой содержатся необходимые данные.
  2. Начальная позиция – это непосредственно положение того символа, который и служит началом для извлечения текста.
  3. Число знаков – количество символов, которые формула должна вытащить из текста.

На практике эта функция может использоваться, например, чтобы упростить названия тайтлов, убрав слова, которые находятся в их начале.

Формула 9: ПРОПИСН

Эта функция все буквы, содержащиеся в определенной строке, делает прописными. Ее синтаксис следующий:

=ПРОПИСН(текст)

Аргумент только один – непосредственно текст, который будет обрабатываться. Можно использовать ссылку на ячейку.

Формула 10: СТРОЧН

По сути, обратная функция, которая делает строчными каждую букву заданного текста или ячейки.

Синтаксис у нее аналогичный, есть только один аргумент, содержащий текст или адрес ячейки.

Формула 11: ПОИСКПОЗ

Эта функция дает возможность найти требуемый элемент среди диапазона ячеек и выдать его положение.

Шаблон этой формулы такой:

=ПОИСКПОЗ(искомое_значение;просматриваемый_массив;тип_сопоставления)

Первые два аргумента обязательные, последний – нет.

Существует три способа сопоставления:

  1. Меньше или равно – 1.
  2. Точное – 0.
  3. Самое маленькое значение, равно искомому или большего него -1.

В данном примере мы пытаемся определить, какой по какому из ключевых слов осуществляется до 900 переходов включительно.

Формула 12: ДЛСТР

Эта функция дает возможность определить, какая длина у заданной строки.

Ее синтаксис аналогичен предыдущей:

=ДЛСТР(текст)

Так, она может использоваться, чтобы определить длину описания статьи при SEO-продвижении сайта.

Также ее хорошо совмещать с функцией ЕСЛИ.

Формула 13: СЦЕПИТЬ

Эта функция дает возможность сделать несколько строчек из одной. Причем допустимо указание в аргументах как адресов ячеек, так и непосредственно само значение. Формула дает возможность записать до 255 элементов общей длиной не более 8192 символа, чего предостаточно для практики.

Синтаксис такой:

=СЦЕПИТЬ(текст1;текст2;текст3);

Формула 14: ПРОПНАЧ

Эта функция меняет местами прописные и строчные символы.

Синтаксис очень простой:

=ПРОПНАЧ(текст)

Формула 15: ПЕЧСИМВ

Эта формула дает возможность убрать все невидимые знаки (например, перенос строки) из статьи.

Ее синтаксис следующий:

=ПЕЧСИМВ(текст)

В качестве аргумента можно указывать адрес ячейки.

Выводы

Конечно, это не все функции, которые используются в Excel. Мы хотели привести такие, о которых не слышал среднестатистический пользователь электронных таблиц или использует редко. По статистике наиболее часто используются функции для вычисления и выведения среднего значения. Но Excel – это больше среда разработки, чем просто программа для электронных таблиц. В ней можно автоматизировать абсолютно любую функцию. 

Очень хочется надеяться, что это получилось, и вы почерпнули для себя много полезного.

Формула предписывает программе Excel порядок действий с числами, значениями в ячейке или группе ячеек. Без формул электронные таблицы не нужны в принципе.

Конструкция формулы включает в себя: константы, операторы, ссылки, функции, имена диапазонов, круглые скобки содержащие аргументы и другие формулы. На примере разберем практическое применение формул для начинающих пользователей.

Формулы в Excel для чайников

Чтобы задать формулу для ячейки, необходимо активизировать ее (поставить курсор) и ввести равно (=). Так же можно вводить знак равенства в строку формул. После введения формулы нажать Enter. В ячейке появится результат вычислений.

В Excel применяются стандартные математические операторы:

Оператор Операция Пример
+ (плюс) Сложение =В4+7
— (минус) Вычитание =А9-100
* (звездочка) Умножение =А3*2
/ (наклонная черта) Деление =А7/А8
^ (циркумфлекс) Степень =6^2
= (знак равенства) Равно
< Меньше
> Больше
<= Меньше или равно
>= Больше или равно
<> Не равно

Символ «*» используется обязательно при умножении. Опускать его, как принято во время письменных арифметических вычислений, недопустимо. То есть запись (2+3)5 Excel не поймет.

Программу Excel можно использовать как калькулятор. То есть вводить в формулу числа и операторы математических вычислений и сразу получать результат.

Но чаще вводятся адреса ячеек. То есть пользователь вводит ссылку на ячейку, со значением которой будет оперировать формула.

При изменении значений в ячейках формула автоматически пересчитывает результат.

Ссылки можно комбинировать в рамках одной формулы с простыми числами.

Оператор умножил значение ячейки В2 на 0,5. Чтобы ввести в формулу ссылку на ячейку, достаточно щелкнуть по этой ячейке.

В нашем примере:

  1. Поставили курсор в ячейку В3 и ввели =.
  2. Щелкнули по ячейке В2 – Excel «обозначил» ее (имя ячейки появилось в формуле, вокруг ячейки образовался «мелькающий» прямоугольник).
  3. Ввели знак *, значение 0,5 с клавиатуры и нажали ВВОД.

Если в одной формуле применяется несколько операторов, то программа обработает их в следующей последовательности:

  • %, ^;
  • *, /;
  • +, -.

Поменять последовательность можно посредством круглых скобок: Excel в первую очередь вычисляет значение выражения в скобках.

Как в формуле Excel обозначить постоянную ячейку

Различают два вида ссылок на ячейки: относительные и абсолютные. При копировании формулы эти ссылки ведут себя по-разному: относительные изменяются, абсолютные остаются постоянными.

Все ссылки на ячейки программа считает относительными, если пользователем не задано другое условие. С помощью относительных ссылок можно размножить одну и ту же формулу на несколько строк или столбцов.

  1. Вручную заполним первые графы учебной таблицы. У нас – такой вариант:
  2. Вспомним из математики: чтобы найти стоимость нескольких единиц товара, нужно цену за 1 единицу умножить на количество. Для вычисления стоимости введем формулу в ячейку D2: = цена за единицу * количество. Константы формулы – ссылки на ячейки с соответствующими значениями.
  3. Нажимаем ВВОД – программа отображает значение умножения. Те же манипуляции необходимо произвести для всех ячеек. Как в Excel задать формулу для столбца: копируем формулу из первой ячейки в другие строки. Относительные ссылки – в помощь.

Находим в правом нижнем углу первой ячейки столбца маркер автозаполнения. Нажимаем на эту точку левой кнопкой мыши, держим ее и «тащим» вниз по столбцу.

Отпускаем кнопку мыши – формула скопируется в выбранные ячейки с относительными ссылками. То есть в каждой ячейке будет своя формула со своими аргументами.

Ссылки в ячейке соотнесены со строкой.

Формула с абсолютной ссылкой ссылается на одну и ту же ячейку. То есть при автозаполнении или копировании константа остается неизменной (или постоянной).

Чтобы указать Excel на абсолютную ссылку, пользователю необходимо поставить знак доллара ($). Проще всего это сделать с помощью клавиши F4.

  1. Создадим строку «Итого». Найдем общую стоимость всех товаров. Выделяем числовые значения столбца «Стоимость» плюс еще одну ячейку. Это диапазон D2:D9
  2. Воспользуемся функцией автозаполнения. Кнопка находится на вкладке «Главная» в группе инструментов «Редактирование».
  3. После нажатия на значок «Сумма» (или комбинации клавиш ALT+«=») слаживаются выделенные числа и отображается результат в пустой ячейке.

Сделаем еще один столбец, где рассчитаем долю каждого товара в общей стоимости. Для этого нужно:

  1. Разделить стоимость одного товара на стоимость всех товаров и результат умножить на 100. Ссылка на ячейку со значением общей стоимости должна быть абсолютной, чтобы при копировании она оставалась неизменной.
  2. Чтобы получить проценты в Excel, не обязательно умножать частное на 100. Выделяем ячейку с результатом и нажимаем «Процентный формат». Или нажимаем комбинацию горячих клавиш: CTRL+SHIFT+5
  3. Копируем формулу на весь столбец: меняется только первое значение в формуле (относительная ссылка). Второе (абсолютная ссылка) остается прежним. Проверим правильность вычислений – найдем итог. 100%. Все правильно.

При создании формул используются следующие форматы абсолютных ссылок:

  • $В$2 – при копировании остаются постоянными столбец и строка;
  • B$2 – при копировании неизменна строка;
  • $B2 – столбец не изменяется.

Как составить таблицу в Excel с формулами

Чтобы сэкономить время при введении однотипных формул в ячейки таблицы, применяются маркеры автозаполнения. Если нужно закрепить ссылку, делаем ее абсолютной. Для изменения значений при копировании относительной ссылки.

Простейшие формулы заполнения таблиц в Excel:

  1. Перед наименованиями товаров вставим еще один столбец. Выделяем любую ячейку в первой графе, щелкаем правой кнопкой мыши. Нажимаем «Вставить». Или жмем сначала комбинацию клавиш: CTRL+ПРОБЕЛ, чтобы выделить весь столбец листа. А потом комбинация: CTRL+SHIFT+»=», чтобы вставить столбец.
  2. Назовем новую графу «№ п/п». Вводим в первую ячейку «1», во вторую – «2». Выделяем первые две ячейки – «цепляем» левой кнопкой мыши маркер автозаполнения – тянем вниз.
  3. По такому же принципу можно заполнить, например, даты. Если промежутки между ними одинаковые – день, месяц, год. Введем в первую ячейку «окт.15», во вторую – «ноя.15». Выделим первые две ячейки и «протянем» за маркер вниз.
  4. Найдем среднюю цену товаров. Выделяем столбец с ценами + еще одну ячейку. Открываем меню кнопки «Сумма» — выбираем формулу для автоматического расчета среднего значения.

Чтобы проверить правильность вставленной формулы, дважды щелкните по ячейке с результатом.

Работа каждого современного специалиста, непременно, связана с цифрами, с отчетностью и, возможно, финансовым моделированием.

Большинство компаний используют для финансового моделирования и управления Excel, т.к. это простой и доступный инструмент. Excel содержит сотни полезных для специалистов функций.

В этой статье мы расскажем вам о 13 популярных базовых функций Excel, которые должен знать каждый специалист!

Без опытного помощника разбираться в этом очень долго. Можно потратить годы профессиональной жизни, не зная и трети возможностей Excel, экономящих сотни рабочих часов в год.

Освоить весь функционал программы и поднять свои навыки владения Excel на небывалый уровень вы сможете на нашем курсе по Excel/VBA.

Итак, основные функции, используемые в Excel.

1. Функция СУММ (SUM)

  • Русская версия: СУММ (Массив 1, Массив 2…..);
  • Английская версия: SUM (Arr 1, Arr 2…..)

Показывает сумму всех аргументов внутри формулы.

Пример: СУММ(1;2;3)=6 или СУММ (А1;B1;C1), т.е. сумма значений в ячейках.

2. Функция ПРОИЗВЕД (PRODUCT)

  • Русская версия: ПРОИЗВЕД (Массив 1, Массив 2…..);
  • Английская версия: PRODUCT (Arr 1, Arr 2…..)

Выполняет умножение аргументов.

Пример: ПРОИЗВЕД(1;2;3)=24 или ПРОИЗВЕД(А1;B1;C1), т.е. произведение значений в ячейках.

3. Функция ЕСЛИ (IF)

  • Русская версия: ЕСЛИ (Выражение 1; Результат ЕСЛИ Истина, Результат ЕСЛИ Ложь);
  • Английская версия: IF (Expr 1, Result IF True, Result IF False)/

Для функции возможны два результата.

Первый результат возвращается в случае, если сравнение – истина, второй — если сравнение ложно.

Пример: А15=1. Тогда, =ЕСЛИ(А15=1;2;3)=2. Если поменять значение ячейки А15 на 2, тогда получим: =ЕСЛИ(А15=1;2;3)=3/

С помощью функции ЕСЛИ строят древо решения:

Формула для древа будет следующая:

ЕСЛИ(А22=1; ЕСЛИ(А235;10); ЕСЛИ(А248;6)). ЕСЛИ А22=1, А23=-5, А24=6, то возвращается результат 5.

4. Функция СУММПРОИЗВ(SUMPRODUCT)

  • Русская версия: СУММПРОИЗВ(Массив 1;  Массив 2;…..)    
  • Английская версия: SUMPRODUCT(Array 1; Array 2;…..)

Умножает соответствующие аргументы заданных массивов и возвращает сумму произведений.

Пример: найти сумму произведений

Находим произведения:

ПРОИЗВ1 =1*2*3=6

ПРОИЗВ2 =4*5*6=120

ПРОИЗВ3 =7*8*9=504

Сумма произведений равна 6+120+504=630

Эти расчеты можно заменить функцией СУММПРОИЗВ.

= СУММПРОИЗВ(Массив 1;  Массив 2; Массив 3)

5. Функция СРЗНАЧ (AVERAGE)

  • Русская версия: СРЗНАЧ (Массив 1;  Массив 2;…..)  
  • Английская версия: AVERAGE(Array 1; Array 2;…..)

Рассчитывает среднее арифметическое всех аргументов.

Пример: СРЗНАЧ (1; 2; 3; 4; 5)=3  

6. Функция МИН (MIN)

  • Русская версия: МИН (Массив 1;  Массив 2;…..)  
  • Английская версия: MIN(Array 1; Array 2;…..)

Возвращает минимальное значение массивов.

Пример: МИН(1; 2; 3; 4; 5)=1  

7. Функция МАКС (MAX)

  • Русская версия: МАКС (Массив 1;  Массив 2;…..)  
  • Английская версия: MAX(Array 1; Array 2;…..)

Обратная функции МИН. Возвращает максимальное значение массивов.

Пример: МАКС(1; 2; 3; 4; 5)=5

8. Функция НАИМЕНЬШИЙ (SMALL)

  • Русская версия: НАИМЕНЬШИЙ (Массив 1;  Порядок k)   
  • Английская версия: SMALL(Array 1, k-min)

Возвращает k наименьшее число после минимального. Если k=1, возвращаем минимальное число.

Пример: В ячейках А1;A5  находятся числа 1;3;6;5;10.

Результат функции =НАИМЕНЬШИЙ (A1;A5) при разных k:

k=1; результат =1

k=2; результат=2

k=3; результат=5

9. Функция НАИБОЛЬШИЙ (LARGE)

  • Русская версия: НАИБОЛЬШИЙ (Массив 1;  Порядок k)   
  • Английская версия: LARGE(Array 1, k-min)

Возвращает k наименьшее число после максимального. Если k=1, возвращаем максимальное число.

Пример: в ячейках А1;A5  находятся числа 1;3;6;5;10.

Результат функции = НАИБОЛЬШИЙ (A1;A5) при разных k:

k=1;  результат =10

k=2; результат=6

k=3; результат=5

10. Функция ВПР(VLOOKUP)

  • Русская версия: ВПР(искомое значение; таблица; номер столбца; {0 (ЛОЖЬ, т.е. точное значение);1(ИСТИНА, т.е. приблизительное значение)})    
  • Английская версия: VLOOKUP(lookup value, table, column number. {0;1})

Ищет значения в столбцах массива и выдает значение в найденной строке и указанном столбце.

Пример: Есть таблица находящаяся в ячейках А1;С4

Нужно найти (ищем в ячейку А6):

  1. Возраст сотрудника Иванова (3 столбец)
  2. ВУЗ сотрудника Петрова (2 столбец)

Составляем формулы:

  1. ВПР(А6; А1:С4; 3;0) Формула ищет значение «Иванов» в первом столбце таблицы А1;С4 и возвращает значение в строке 3 столбца. Результат функции – 22
  2. ВПР(А6; А1:С4; 2;0) Формула ищет значение «Петров» в первом столбце таблицы А1;С4 и возвращает значение в строке 2 столбца. Результат функции – ВШЭ

11. Функция ИНДЕКС(INDEX)

  • Русская версия: ИНДЕКС (Массив;Номер строки;Номер столбца);
  • Английская версия: INDEX(table, row number, column number)

Ищет значение пересечение на указанной строки и столбца массива.

Пример: Есть таблица находящаяся в ячейках А1;С4

Необходимо написать формулу, которая выдаст значение «Петров».

«Петров» расположен на пересечении 3 строки и 1 столбца, соответственно, формула принимает вид: =ИНДЕКС(А1;С4;3;1).

12. Функция СУММЕСЛИ(SUMIF)

  • Русская версия: СУММЕСЛИ(диапазон для критерия; критерий; диапазон суммирования)
  • Английская версия: SUMIF(criterion range; criterion; sumrange)

Суммирует значения в определенном диапазоне, которые попадают под определенные критерии.

Пример: в ячейках А1;C5

Найти:

  1. Количество столовых приборов сделанных из серебра.
  2. Количество приборов <=15.

Решение:

  1. Выражение  =СУММЕСЛИ(А1:C5;«Серебро»; В1:B5). Результат = 40 (15+25).
  2. =СУММЕСЛИ(В1:В5;« <=» & 15; В1:B5). Результат = 25 (15+10).

13. Функция СУММЕСЛИМН(SUMIF)

  • Русская версия: СУММЕСЛИ(диапазон суммирования; диапазон критерия 1; критерий 1; диапазон критерия 2; критерий 2;…)
  • Английская версия: SUMIFS(criterion range; criterion; sumrange; criterion 1; criterion range 1; criterion 2; criterion range 2;)

Суммирует значения в диапазоне, который попадает под определенные критерии.

Пример: в ячейках А1;C5 есть следующие данные

Найти:

  1. Количество столовых приборов сделанных из серебра, единичное количество которых <=20.

Решение:

  1. Выражение  =СУММЕСЛИМН(В1:В5; С1:С5; «Серебро»; В1:B5;« <=» & 20). Результат = 15

Заключение

Excel позволяет сократить время для решения некоторых задач, повысить оперативность, а это, как известно, важный фактор для эффективности.

Многие формулы выше также используются в финансовом моделировании.

В статье представлены только часть популярных функции Excel. А еще в Excel есть сотни других формул, диаграмм и массивов данных.

Узнать больше формул и диаграмм, отточить их на примерах, научиться работать с расширенным функционалом Excel, вы можете на нашем курсе по Excel/VBA.

11 апреля 20181922361

Не нужно тратить время на подсчёты в Microsoft Excel вручную, ведь существует множество формул, которые помогут быстро справиться с поставленными задачами и повысить точность ваших отчётов. Мы собрали 10 наиболее полезных формул, которые вы сможете выучить за один день.

СУММ

Формула:

=СУММ(число1; число2)

=СУММ(адрес_ячейки1; адрес_ячейки2)

=СУММ(адрес_ячейки1:адрес_ячейки6)

Англоязычный вариант: =SUM(5; 5) или =SUM(A1; B1) или =SUM(A1:B5)

Функция СУММ позволяет вычислить сумму двух или более чисел. В этой формуле вы также можете использовать ссылки на ячейки.

С помощью формулы вы можете:

  • посчитать сумму двух чисел c помощью формулы: =СУММ(5; 5)
  • посчитать сумму содержимого ячеек, сссылаясь на их названия: =СУММ(A1; B1)
  • посчитать сумму в указанном диапазоне ячеек, в примере во всех ячейках с A1 по B6: =СУММ(A1:B6)

СЧЁТ

Формула: =СЧЁТ(адрес_ячейки1:адрес_ячейки2)

Англоязычный вариант: =COUNT(A1:A10)

Данная формула подсчитывает количество ячеек с числами в одном ряду. Если вам необходимо узнать, сколько ячеек с числами находятся в диапазоне c A1 по A30, нужно использовать следующую формулу: =СЧЁТ(A1:A30).

СЧЁТЗ

Формула: =СЧЁТЗ(адрес_ячейки1:адрес_ячейки2)

Англоязычный вариант: =COUNTA(A1:A10)

С помощью данной формулы можно подсчитать количество заполненных ячеек в одном ряду, то есть тех, в которых есть не только числа, но и другие знаки. Преимущество формулы – её можно использовать для работы с любым типом данных.

ДЛСТР

Формула: =ДЛСТР(адрес_ячейки)

Англоязычный вариант: =LEN(A1)

Функция ДЛСТР подсчитывает количество знаков в ячейке. Однако, будьте внимательны – пробел также учитывается как знак.

СЖПРОБЕЛЫ

Формула: =СЖПРОБЕЛЫ(адрес_ячейки)

Англоязычный вариант: =TRIM(A1)

Данная функция помогает избавиться от пробелов, не включая при этом пробелы между словами. Эта опция может быть чрезвычайно полезной, особенно в тех ситуациях, когда вы вносите в таблицу данные из другого источника и при вставке появляются лишние пробелы.

Мы добавили лишний пробел после фразы “Я люблю Excel”. Формула СЖПРОБЕЛЫ убрала его, в этом вы можете убедиться, взглянув на количество знаков с использованием формулы и без.

ЛЕВСИМВ, ПСТР и ПРАВСИМВ

Формула:

=ЛЕВСИМВ(адрес_ячейки; количество знаков)

=ПРАВСИМВ(адрес_ячейки; количество знаков)

=ПСТР(адрес_ячейки; начальное число; число знаков)

Англоязычный вариант: =RIGHT(адрес_ячейки; число знаков), =LEFT(адрес_ячейки; число знаков), =MID(адрес_ячейки; начальное число; число знаков).

Эти формулы возвращают заданное количество знаков текстовой строки. ЛЕВСИМВ возвращает заданное количество знаков из указанной строки слева, ПРАВСИМВ возвращает заданное количество знаков из указанной строки справа, а ПСТР возвращает заданное число знаков из текстовой строки, начиная с указанной позиции.

Мы использовали ЛЕВСИМВ, чтобы получить первое слово. Для этого мы ввели A1 и число 1 – таким образом, мы получили «Я».

Мы использовали ПСТР, чтобы получить слово посередине. Для этого мы ввели А1, поставили 3 как начальное число и затем ввели число 6 – таким образом, мы получили «люблю» из фразы «Я люблю Excel».

Мы использовали ПРАВСИМВ, чтобы получить последнее слово. Для этого мы ввели А1 и число 6 – таким образом, мы получили слово «Excel» из фразы «Я люблю Excel».

ВПР

Формула: =ВПР(искомое_значение; таблица; номер_столбца; тип_совпадения)

Англоязычный вариант: =VLOOKUP (искомое_значение; таблица; номер_столбца; тип_совпадения)

Функция ВПР работает как телефонная книга, где по фрагменту известных данных – имени, вы находите неизвестные сведения – номер телефона. В формуле необходимо задать искомое значение, которое формула должна найти в столбце таблицы.

Например, у вас есть два списка: первый с паспортными данными сотрудников и их доходами от продаж за последний квартал, а второй – с их паспортными данными и именами. Вы хотите сопоставить имена с доходами от продаж, но, делая это вручную, можно легко ошибиться.

  1. В первом списке данные записаны с А1 по В13, во втором – с D1 по Е13.
  2. В ячейке B17 поставим формулу: =ВПР(B16; A1:B13; 2; ЛОЖЬ)
  • B16 = искомое значение, то есть паспортные данные. Они имеются в обоих списках.
  • A1:B13 = таблица, в которой находится искомое значение.
  • 2 – номер столбца, где находится искомое значение.
  • ЛОЖЬ – логическое значение, которое означает то, что вам требуется точное совпадение возвращаемого значения. Если вам достаточно приблизительного совпадения, указываете ИСТИНА, оно также является значением по умолчанию.

Эта формула не такая простая, как предыдущие, тем не менее она очень полезна в работе.

ЕСЛИ

Формула: =ЕСЛИ(логическое_выражение; «текст, если логическое выражение истинно; «текст, если логическое выражение ложно»)

Англоязычный вариант: =IF(логическое_выражение; «текст, если логическое выражение истинно; «текст, если логическое выражение ложно»)

Когда вы проводите анализ большого объёма данных в Excel, есть множество сценариев для взаимодействия с ними. В зависимости от каждого из них появляется необходимость по‑разному воздействовать на данные. Функция «ЕСЛИ» позволяет выполнять логические сравнения значений: если что‑то истинно, то необходимо сделать это, в противном случае сделать что‑то ещё.

Снова обратимся к примеру из сферы продаж: допустим, что у каждого продавца есть установленная норма по продажам. Вы использовали формулу ВПР, чтобы поместить доход рядом с именем. Теперь вы можете использовать оператор «ЕСЛИ», который будет выражать следующее: «ЕСЛИ продавец выполнил норму, вывести выражение «Норма выполнена», если нет, то «Норма не выполнена».

В примере с ВПР у нас был доход в столбце B и имя человека в столбце E. Мы можем поместить квоту в столбце C, а следующую формулу – в ячейку D1:

=ЕСЛИ(B1>C1; «Норма выполнена»; «Норма не выполнена»)

Функция «ЕСЛИ» покажет нам, выполнил ли первый продавец свою норму или нет. После можно скопировать и вставить эту формулу для всех продавцов в списке, значение автоматически изменится для каждого работника.

СУММЕСЛИ, СЧЁТЕСЛИ, СРЗНАЧЕСЛИ

Формула: =СУММЕСЛИ(диапазон; условие; диапазон_суммирования) =СЧЁТЕСЛИ(диапазон; условие)

=СРЗНАЧЕСЛИ(диапазон; условие; диапазон_усреднения)

Англоязычный вариант: =SUMIF(диапазон; условие; диапазон_суммирования), =COUNTIF(диапазон; условие), =AVERAGEIF(диапазон; условие; диапазон_усреднения)

Эти формулы выполняют соответствующие функции – СУММ, СЧЁТ, СРЗНАЧ, если выполнено заданное условие.

Формулы с несколькими условиями – СУММЕСЛИМН, СЧЁТЕСЛИМН, СРЗНАЧЕСЛИМН – выполняют соответствующие функции, если все указанные критерии соответствуют истине.

Используя функции на предыдущем примере, мы можем узнать:

Формула «СУММЕСЛИ»

СУММЕСЛИ – общий доход только для продавцов, выполнивших норму.

Формула «СРЗНАЧЕСЛИ»

СРЗНАЧЕСЛИ – средний доход продавца, если он выполнил норму.

Формула «СЧЁТЕСЛИ»

СЧЁТЕСЛИ – количество продавцов, выполнивших норму.

Конкатенация

Формула: =(ячейка1&» «&ячейка2)

=ОБЪЕДИНИТЬ(ячейка1;» «;ячейка2)

За этим причудливым словом скрывается объединение данных из двух и более ячеек в одной. Сделать объединение можно с помощью формулы конкатенации или просто вставив символ & между адресами двух ячеек. Если в ячейке A1 находится имя «Иван», в ячейке B1 – фамилия «Петров», их можно объединить с помощью формулы =A1&» «&B1. Результат – «Иван Петров» в ячейке, где была введена формула. Обязательно оставьте пробел между » «, чтобы между объединёнными данными появился пробел.

Формула конкатенации даёт аналогичный эффект и выглядит так: =ОБЪЕДИНИТЬ(A1;» «; B1) или в англоязычном варианте =concatenate(A1;» «; B1).

Кстати, все перечисленные формулы можно применять и в Google‑таблицах.

Эта статья является лишь верхушкой айсберга в изучении Excel. Для профессионального использования программы рекомендуем учится у профессионалов на курсах по Microsoft Excel.

Здравствуйте!

Многие кто не пользуются Excel — даже не представляют, какие возможности дает эта программа! ☝

Подумать только: складывать в автоматическом режиме значения из одних формул в другие, искать нужные строки в тексте, создавать собственные условия и т.д. — в общем-то, по сути мини-язык программирования для решения «узких» задач (признаться честно, я сам долгое время Excel не рассматривал за программу, и почти его не использовал).

В этой статье хочу показать несколько примеров, как можно быстро решать повседневные  офисные задачи: что-то сложить, вычесть, посчитать сумму (в том числе и с условием), подставить значения из одной таблицы в другую и т.д.

То есть эта статья будет что-то мини гайда по обучению самому нужному для работы (точнее, чтобы начать пользоваться Excel и почувствовать всю мощь этого продукта!).

Возможно, что прочти подобную статью лет 17-20 назад, я бы сам намного быстрее начал пользоваться Excel (и сэкономил бы кучу своего времени для решения «простых» задач…👌

*

Обучение основам Excel: ячейки и числа

Примечание: все скриншоты ниже представлены из программы Excel 2016 (как одной из самой новой на сегодняшний день).

Многие начинающие пользователи, после запуска Excel — задают один странный вопрос: «ну и где тут таблица?». Между тем, все клеточки, что вы видите после запуска программы — это и есть одна большая таблица!

Теперь к главному: в любой клетке может быть текст, какое-нибудь число, или формула. Например, ниже на скриншоте показан один показательный пример:

  • слева: в ячейке (A1) написано простое число «6». Обратите внимание, когда вы выбираете эту ячейку, то в строке формулы (Fx) показывается просто число «6».
  • справа: в ячейке (C1) с виду тоже простое число «6», но если выбрать эту ячейку, то вы увидите формулу «=3+3» — это и есть важная фишка в Excel!

Просто число (слева) и посчитанная формула (справа)

👉 Суть в том, что Excel может считать как калькулятор, если выбрать какую нибудь ячейку, а потом написать формулу, например «=3+5+8» (без кавычек). Результат вам писать не нужно — Excel посчитает его сам и отобразит в ячейке (как в ячейке C1 в примере выше)!

Но писать в формулы и складывать можно не просто числа, но и числа, уже посчитанные в других ячейках. На скриншоте ниже в ячейке A1 и B1 числа 5 и 6 соответственно. В ячейке D1 я хочу получить их сумму — можно написать формулу двумя способами:

  • первый: «=5+6»(не совсем удобно, представьте, что в ячейке A1 — у нас число тоже считается по какой-нибудь другой формуле и оно меняется. Не будете же вы подставлять вместо 5 каждый раз заново число?!);
  • второй: «=A1+B1» — а вот это идеальный вариант, просто складываем значение ячеек A1 и B1 (несмотря даже какие числа в них!).

Сложение ячеек, в которых уже есть числа

Распространение формулы на другие ячейки

В примере выше мы сложили два числа в столбце A и B в первой строке. Но строк то у нас 6, и чаще всего в реальных задачах сложить числа нужно в каждой строке! Чтобы это сделать, можно:

  1. в строке 2 написать формулу «=A2+B2», в строке 3 — «=A3+B3» и т.д. (это долго и утомительно, этот вариант никогда не используют);
  2. выбрать ячейку D1 (в которой уже есть формула), затем подвести указатель мышки к правому уголку ячейки, чтобы появился черный крестик (см. скрин ниже). Затем зажать левую кнопку и растянуть формулу на весь столбец. Удобно и быстро! (Примечание: так же можно использовать для формул комбинации Ctrl+C и Ctrl+V (скопировать и вставить соответственно)).

Растягивание формулы

Кстати, обратите внимание на то, что Excel сам подставил формулы в каждую строку. То есть, если сейчас вы выберите ячейку, скажем, D2 — то увидите формулу «=A2+B2»(т.е. Excel автоматически подставляет формулы и сразу же выдает результат).

Как задать константу (ячейку, которая не будет меняться при копировании формулы)

Довольно часто требуется в формулах (когда вы их копируете), чтобы какой-нибудь значение не менялось. Скажем простая задача: перевести цены в долларах в рубли. Стоимость рубля задается в одной ячейке, в моем примере ниже — это G2.

Далее в ячейке E2 пишется формула «=D2*G2» и получаем результат. Только вот если растянуть формулу, как мы это делали до этого,  в других строках результата мы не увидим, т.к. Excel в строку 3 поставит формулу «D3*G3», в 4-ю строку: «D4*G4» и т.д. Надо же, чтобы G2 везде оставалась G2…

Чтобы это сделать — просто измените ячейку E2 — формула будет иметь вид  «=D2*$G$2». Т.е. значок доллара $ — позволяет задавать ячейку, которая не будет меняться, когда вы будете копировать формулу (т.е. получаем константу, пример ниже).

Константа / в формуле ячейка не изменяется

*

Как посчитать сумму (формулы СУММ и СУММЕСЛИМН)

Можно, конечно, составлять формулы в ручном режиме, печатая «=A1+B1+C1» и т.п. Но в Excel есть более быстрые и удобные инструменты.

Один из самых простых способов сложить все выделенные ячейки — это использовать опцию автосуммы(Excel сам напишет формулу и вставить ее в ячейку).

Что нужно сделать, чтобы посчитать сумму определенных ячеек:

  1. сначала выделяем ячейки (см. скрин ниже 👇);
  2. далее открываем раздел «Формулы»;
  3. следующий шаг жмем кнопку «Автосумма». Под выделенными вами ячейками появиться результат из сложения;
  4. если выделить ячейку с результатом (в моем случае — это ячейка E8) — то вы увидите формулу «=СУММ(E2:E7)».
  5. таким образом, написав формулу «=СУММ(xx)», где вместо xx поставить (или выделить) любые ячейки, можно считать самые разнообразные диапазоны ячеек, столбцов, строк…

Автосумма выделенных ячеек

Как посчитать сумму с каким-нибудь условием

Довольно часто при работе требуется не просто сумма всего столбца, а сумма определенных строк (т.е. выборочно). Предположим простую задачу: нужно получить сумму прибыли от какого-нибудь рабочего (утрировано, конечно, но пример более чем реальный).

Я в своей таблицы буду использовать всего 7 строк (для наглядности), реальная же таблица может быть намного больше. Предположим, нам нужно посчитать всю прибыль, которую сделал «Саша». Как будет выглядеть формула:

  1. «=СУММЕСЛИМН(F2:F7;A2:A7;»Саша»)» — (прим.: обратите внимание на кавычки для условия — они должны быть как на скрине ниже, а не как у меня сейчас написано на блоге). Так же обратите внимание, что Excel при вбивании начала формулы (к примеру «СУММ…»), сам подсказывает и подставляет возможные варианты — а формул в Excel’e сотни!;
  2. F2:F7 — это диапазон, по которому будут складываться (суммироваться) числа из ячеек;
  3. A2:A7 — это столбик, по которому будет проверяться наше условие;
  4. «Саша» — это условие, те строки, в которых в столбце A будет «Саша» будут сложены (обратите внимание на показательный скриншот ниже).

Сумма с условием

Примечание: условий может быть несколько и проверять их можно по разным столбцам.

*

Как посчитать количество строк (с одним, двумя и более условием)

Довольно типичная задача: посчитать не сумму в ячейках, а количество строк, удовлетворяющих какомe-либо условию.

Ну, например, сколько раз имя «Саша» встречается в таблице ниже (см. скриншот). Очевидно, что 2 раза (но это потому, что таблица слишком маленькая и взята в качестве наглядного примера). А как это посчитать формулой?

Формула:

«=СЧЁТЕСЛИ(A2:A7;A2)» — где:

  • A2:A7 — диапазон, в котором будут проверяться и считаться строки;
  • A2 — задается условие (обратите внимание, что можно было написать условие вида «Саша», а можно просто указать ячейку).

Результат показан в правой части на скрине ниже.

Количество строк с одним условием

Теперь представьте более расширенную задачу: нужно посчитать строки, где встречается имя «Саша», и где в столбце «B» будет стоять цифра «6». Забегая вперед, скажу, что такая строка всего лишь одна (скрин с примером ниже).

Формула будет иметь вид:

=СЧЁТЕСЛИМН(A2:A7;A2;B2:B7;»6″)  — (прим.: обратите внимание на кавычки — они должны быть как на скрине ниже, а не как у меня), где:

A2:A7;A2 — первый диапазон и условие для поиска (аналогично примеру выше);

B2:B7;»6″ — второй диапазон и условие для поиска (обратите внимание, что условие можно задавать по разному: либо указывать ячейку, либо просто написано в кавычках текст/число).

Счет строк с двумя и более условиями

*

Как посчитать процент от суммы

Тоже довольно распространенный вопрос, с которым часто сталкиваюсь. Вообще, насколько я себе представляю, возникает он чаще всего — из-за того, что люди путаются и не знают, что от чего ищут процент (да и вообще, плохо понимают тему процентов (хотя я и сам не большой математик, и все таки… ☝)).

👉 В помощь!

Как посчитать проценты: от числа, от суммы чисел и др. [в уме, на калькуляторе и с помощью Excel] —заметка для начинающих

Самый простой способ, в котором просто невозможно запутаться — это использовать правило «квадрата», или пропорции.

Вся суть приведена на скрине ниже: если у вас есть общая сумма, допустим в моем примере это число 3060 — ячейка F8(т.е. это 100% прибыль, и какую то ее часть сделал «Саша», нужно найти какую…).

По пропорции формула будет выглядеть так: =F10*G8/F8 (т.е. крест на крест: сначала перемножаем два известных числа по диагонали, а затем делим на оставшееся третье число).

В принципе, используя это правило, запутаться в процентах практически невозможно 👌.

Пример решения задач с процентами

*

PS 

Собственно, на этом я завершаю данную статью. Не побоюсь сказать, что освоив все, что написано выше (а приведено здесь всего лишь «пяток» формул) — Вы дальше сможете самостоятельно обучаться Excel, листать справку, смотреть, экспериментировать, и анализировать. 👌

Скажу даже больше, все что я описал выше, покроет многие задачи, и позволит решать всё самое распространенное, над которым часто ломаешь голову (если не знаешь возможности Excel), и даже не догадывается как быстро это можно сделать… ✔

*

Дополнения по теме приветствуются!

Удачи!

👋

Первая публикация: 21.01.2017

Корректировка: 5.01.2020

RSS  (как читать Rss)dzenlink.png

Другие записи:

  • Soft-dlya-sozdaniya-prezentatsiy.pngПрограммы для создания презентаций (для начинающих)
  • Как вырезать из видео нужные фрагменты (куски): без конвертирования! Разделение видео на части // …
  • uTorrent-virus.pnguTorrent — это вирус? Что делать, если uTorrent блокируется защитником (антивирусом)
  • Delaem-znachki-krupnee-melche.jpgКак изменить размер значков на рабочем столе (и что делать, если они не меняются)
  • Polosyi-pri-raspechatke-dokumentov.pngПринтер печатает полосами: что можно сделать для исправления
  • Kak-sdelat-prezentatsiyu.pngКак сделать презентацию: пошаговая инструкция для PowerPoint
  • iz-fayla-OST-v-PST.pngКак конвертировать файлы OST в PST (пару простых вариантов преобразования)
  • Nevidimaya-papka.pngКак скрыть папку и файлы в Windows (+ как показать их и найти после…)

Используемые источники:

  • https://office-guru.ru/excel/formuly-funkcii/top-15-formul-v-excel.html
  • https://exceltable.com/formuly/rabota-v-eksele-s-formulami-i-tablicami
  • https://blog.sf.education/excel-dlya-finansistov-razbor-klyuchevyh-formul/
  • https://blog.teachmeplease.ru/posts/10-formul-excel-kotorye-pomogut-ne-poterjat-rabotu
  • https://ocomp.info/kak-napisat-formulu-v-excel.html

Оцените статью
Рейтинг автора
5
Материал подготовил
Илья Коршунов
Наш эксперт
Написано статей
134
Добавить комментарий