Проверка орфографии и пунктуации онлайн, проверка правописания в тексте

yandex-spell-checker-300x300.jpgПрежде всего, что такое Яндекс Спеллер? Это программа для орфографической проверки текстов на ошибки. Сервис этот предназначен не только для пользователей в первую очередь, но и для писателей, копирайтеров, а также веб-разработчиков и мастеров, так как прежде чем заполнить свой сайт контентом, его можно проверить на ошибки в автоматическом режиме.

И даже не «можно», а «нужно», так как текстовый контент представляет собой «лицо» вашего сайта и предоставляемых услуг. Ничто так не отвернет потенциального покупателя или клиента, как грубые ошибки орфографии в тексте статьи, документа, рекламы или описания товара.

Яндекс Спеллер используется в почтовом сервисе службы и в «Баре» Яндекса. В нем содержится более трех миллионов словоформ русского языка — по содержанию это самый внушительный словарь на просторах Рунета. Кроме этого сервис «владеет» еще двумя языками — украинским (в словаре около двух миллионов словоформ) и английским (приблизительно 150 тысяч словоформ).

Что входит в Яндекс Спеллер?

Как происходит проверка

В основе программы лежит аналитика частоты употребления тех или иных слов, а это помогает осуществлять проверку наиболее точно, а также оказывает помощь при выборе вариантов подсказки. Кроме того в сервисе предусмотрено большое количество разнообразных опций, что позволяет максимально упростить работу и подстроить сервис под себя.

Спеллер постоянно обновляется и дополняется новыми словами (а потому не удивляется словам «плагин», «роутер» или «кэшироваться»). Проверяя сложный текст с терминами, сервис не будет без надобности подчеркивать его красным.

Как использовать

Например, клиент вашего сайта собирается что-то заказывать у вас, заполнить анкету, создать файл с резюме или же написать сообщение. В этих случаях сервис поможет найти ошибки и исправить их автоматически.

Кроме этого, Яндекс Спеллер помогает тем, кто ежедневно загружает огромные объемы текста и физически не может их проверить. В этом случае текст просто вставляется в окно проверки, выбирается команда «Проверить» —  и все неверно написанные слова будут выделены, а ваше время — не затрачено на долгую и утомительную проверку!

Проверка правописания анализирует текст и слова исходя из современных орфографических и лексических правил. Безусловно, не гарантируется стопроцентной вероятности нахождения и исправления всех ошибок, но все же большинство неверных слов будет найдено благодаря проверке из орфографического словаря.

Какие ошибки сервис сможет найти и исправить

1. Если в слове пропущена или, наоборот, есть лишняя буква, ошибка («пррезентация», «прзнтация», «призентация»).

2. Если использован КапсЛок не по назначению («пРЕЗЕНТАЦИЯ»)- так называемая «ошибка капитализации», то есть неправильное написание прописных и строчных букв в слове.

3. Если одно и то же слово ошибочно использовано дважды («Презентация прошла прошла успешно»).

Ошибки пунктуации, грамматики (например, ошибки в согласовании слов) и стилистики онлайн-сервис не находит и не исправляет. Однако они не так бросаются в глаза, как грубейшие ошибки орфографии, а потому пользователи и посетители вашего сайта могут их и не заметить.

Яндекс Спеллер стремится облегчить жизнь пользователя, пользующегося большими объемами контента, не имеющего времени на вдумчивую проверку, и не дает ему забыть правила русского языка.

5a2d02083ec43cd2c330a937493ffac9.jpg

«Если человек умер, он об этом не знает, только другим тяжело. То же самое, когда он тупой…»

И то же самое, когда он безграмотный. К сожалению, невозможно заставить всех людей выучить правила и начать писать без ошибок. Это факт, с которым нужно смириться — ошибки в интернете есть и будут. А что, если подойти к этой проблеме с другой стороны? Как было бы здорово иметь такой браузер, который при открытии страницы проверял бы текст и исправлял все ошибки. Или хотя бы часть. Ведь, по правде говоря, ошибки воспринимаются по-разному: забытая запятая скорее всего останется незамеченной, в то время как какие-нибудь «извени» или «правельно» вызывают кратковременное бешенство. Что будет, если перед чтением страницы пропустить ее через фильтр и исправить орфографию, наподобие того как adblock режет рекламу? Наверняка такие идеи приходили не только мне, но поиски меня ни к чему не привели. Поэтому я решил сам провести такой эксперимент и хочу рассказать о результатах. Забегая вперед, скажу, что результаты получились интересные, но проблему грамотности я таким образом решить не смог.

Тогда зачем эта статья, если ничего не получилось?

Отрицательный результат — тоже результат. Эту статью я пишу по двум причинам: Во-первых, чтобы следующий человек, которому придет эта идея в голову, не изобретал все с нуля, а мог опереться на мои результаты. А во-вторых, вдруг найдется человек, который сможет развить эту идею дальше.

Реализация

Реализация проста — я написал букмарклет (wiki). Загружаем страницу, нажимаем на букмарклет — запускается js-скрипт, который проверяет орфографию и исправляет ошибки. Для проверки орфографии я использовал прекрасный сервис — Яндекс.Спеллер — api.yandex.ru/speller (Условия использования сервиса «API Яндекс.Спеллер» — legal.yandex.ru/speller_api ). Замена выполняется на первое предложенное сервисом слово. Имеется ограничение — запрос не должен превышать 10000 символов. Учитывая то, что 1 русская буква — это 6 символов в URL-encoded виде (буква «а» — это %D0%B0), то получается существенное ограничение. Весь текст приходится разбивать на несколько фрагментов. Для средней страницы какого-нибудь форума приходится выполнять десяток-другой запросов. Для тех, кто хочет испытать скрипт на себе, исходный код — ссылка на bitbucket. То же самое, но в одну строчку:

javascript:(function(){function main(){var text=document.body.innerHTML;text=text.replace(/<.*/g," "),text=text.replace(/[^а-яА-ЯёЁ]/g," "),text=text.replace(/s+/g," ");var fragments=splitByLimit(text,1e4);for(var i=0,len=fragments.length;ilimit&&(fragments.push(fragment.join(" ")),fragment=[],fragmentLen=0),fragment.push(word),fragmentLen+=word.length*6+3,i==words.length-1&&fragments.push(fragment.join(" "))}return fragments}function checkAndReplace(text){var xhr=new XMLHttpRequest;xhr.onreadystatechange=function(){this.readyState==4&&(xhr.status==200?(data=JSON.parse(xhr.responseText),replaceWords(data)):console.log(xhr.status))},xhr.open("GET","http://speller.yandex.net/services/spellservice.json/checkText?options=7&text="+text,!0),xhr.send()}function replaceWords(data){if(!data)return;var body=document.body.innerHTML;for(var i=0,len=data.length;i4){var replacement=''+subst.s[0]+" ";replacement+=''+subst.word.split("").join("")+"";var regexp=new RegExp(subst.word);body=body.replace(regexp,replacement)}}document.body.innerHTML=body}main()})(); 

Чтобы попробовать, нужно создать закладку в браузере и в поле URL вписать этот код.

Результаты

Первые впечатления — изумительно! Исправляет все ошибки. На удивление — исправляет даже географические названия, имена, названия компаний. Вот несколько примеров. Красным выделены исходные слова, зеленым — на что заменилось.Пример 1:Пример 2:Пример 3: Но, к сожалению, не все так радужно. Есть и обратная сторона — ложные срабатывания. Кажется, их даже побольше, чем исправленных ошибок. Особенно это заметно на тематических сайтах с переизбытком всяких терминов и сленга (как Хабр, например).Пример 4:Пример 5: Этот факт огорчает и сводит на нет все плюсы от использования скрипта. Но все же надеюсь, что кому-то мои эксперименты оказались полезными.

Описание

Яндекс.Спеллер — это сервис, который помогает находить и исправлять орфографические ошибки в русском, украинском или английском тексте.

Особенности Яндекс.Спеллер

  • Языковые модели Спеллера включают сотни миллионов слов и словосочетаний.
  • Чтобы обнаруживать ошибки и подбирать замены, Спеллер использует библиотеку машинного обучения CatBoost.
  • Благодаря CatBoost он может расшифровывать искажённые до неузнаваемости слова («адникасниеи» → «одноклассники») и учитывать контекст при поиске опечаток («скучать музыку» → «скачать музыку»).
  • Спеллер не придирается к новым словам, ещё не попавшим в словари.
  • Чтобы встроить Спеллер в приложение, воспользуйтесь API.

1. spec8s 09.11.17 23:00 Совсем недавно делал нечто подобное, т. к. веб-сервис перестал работать. Только метод чтения XML возможно немного короче:

         ЧтениеXML = Новый ЧтениеXML(); ЧтениеXML.УстановитьСтроку(HttpОтвет.ПолучитьТелоКакСтроку());  ПостроительDOM = Новый ПостроительDOM; ДокументDOM = ПостроительDOM.Прочитать(ЧтениеXML);  РезультатПроверки = Новый Структура("error", Новый Массив);  ЭлементыError = ДокументDOM.ПолучитьЭлементыПоИмени("Error"); Для Каждого ЭлементError Из ЭлементыError Цикл СтруктураОшибок = Новый Структура("s", Новый Массив); Для Каждого АтрибутError Из ЭлементError.Атрибуты Цикл СтруктураОшибок.Вставить(АтрибутError.Имя, Число(АтрибутError.Значение)); КонецЦикла;  ЭлементыWord = ЭлементError.ПолучитьЭлементыПоИмени("word"); СтруктураОшибок.Вставить("word", ЭлементыWord[0].ТекстовоеСодержимое);  ЭлементыS = ЭлементError.ПолучитьЭлементыПоИмени("s"); Для Каждого ЭлементS Из ЭлементыS Цикл СтруктураОшибок.s.Добавить(ЭлементS.ТекстовоеСодержимое); КонецЦикла;  Если СтруктураОшибок.s.Количество() > 0 Тогда РезультатПроверки.error.Добавить(СтруктураОшибок); КонецЕсли; КонецЦикла; 

Показать adhocprog; 🅵🅾️🆇; +2Ответитьtext.ru.png

Сервис проверки орфографии и пунктуации онлайн — это уникальный бесплатный сервис поиска ошибок и опечаток.

Эффективный алгоритм Text.ru находит множество ошибок, среди которых:

  • непарные скобки и апострофы;
  • две запятые или точки подряд;
  • выделение запятыми вводных слов;
  • ошибки в согласовании;
  • грамматические и логические ошибки;
  • опечатки;
  • лишние пробелы;
  • повтор слов;
  • строчная буква в начале предложения;
  • правописание через дефис;
  • и многое другое.

На нашем сервисе вы сможете не только узнать уникальность текста, но и проверить его орфографию и пунктуацию. При проверке текста можно так же легко избавиться и от опечаток, которые не всегда заметны при быстром наборе. При использовании данного сервиса вы будете уверены в качестве текста.

Исправление ошибок в тексте онлайн, проверка орфографии и пунктуации позволят проверить грамотность текста.

Проверка ошибок онлайн поможет найти ошибки и опечатки в тексте. Проверка текста на ошибки пригодится при анализе любого текста, если вы хотите проверить его качество и найти имеющиеся ошибки. Если же у вас возникают трудности в первую очередь с пунктуацией, а не с орфографией, оцените возможность проверки запятых. Сервис укажет на проблемные места, где были найдены лишние или отсутствующие знаки препинания, например, несколько запятых подряд или непарные скобки.

Одной из ключевых особенностей бесплатной проверки на ошибки на Text.ru является возможность исправить их прямо в тексте. Алгоритм проверки прост.

  • Вставьте нужный текст в окно проверки орфографии и пунктуации.
  • Нажмите на кнопку «Проверить на ошибки».
  • Обратите внимание на подсвеченные контрастным цветом места и количество найденных ошибок под полем проверки.
  • Нажмите на выделенное слово и выберите верный вариант написания из открывшегося списка.

Если вы цените свое время, рекомендуем проверить орфографию и пунктуацию онлайн на Text.ru и оценить преимущества самостоятельно.

Проверка правописания текста доступна через API. Подробнее в API-проверке.

Используемые источники:

  • https://softgallery.ru/yandex-speller/
  • https://habr.com/ru/post/225911/
  • https://bizzapps.ru/p/yandex-speller/
  • https://infostart.ru/public/698583/
  • https://text.ru/spelling

Оцените статью
Рейтинг автора
5
Материал подготовил
Илья Коршунов
Наш эксперт
Написано статей
134
7th-studio.ru
Добавить комментарий