Как посчитать сумму ячеек в экселе несколькими классными способами?

Excel – офисная программа от компании Microsoft, которая предназначена для работы с данными в таблицах. С ее помощью можно удобно и быстро проводить операции с числовым и текстовым содержанием ячеек, включая подсчет суммы. Узнать сумму в Экселе возможно несколькими способами, которые рассмотрим в статье.

Содержание

Эксель автоматически производит различные операции, которые упрощают работу с числовыми и текстовыми данными. При использовании функций и инструментов пользователь может тонко настроить подсчет результата, задать условия, использовать формулы, работать одновременно с несколькими таблицами на разных листах документа.

Самый простой способ посчитать сумму определенных ячеек – это их выделение. Программа автоматически произведет расчет и отобразит результат в панели внизу. Если нужно выделить несколько ячеек в разных местах, то для этого нужно воспользоваться клавишей Ctrl: зажать ее и мышкой выбрать нужные для подсчета элементы таблицы.

image001-820x572.png

Способ пригодится, если нет необходимости зафиксировать результат решения. Около значения суммы отображается также количество элементов, которые участвуют в подсчете, а также их среднее арифметическое число.

Чтобы сложить несколько чисел, которые находятся в разных местах, с помощью формулы, воспользуйтесь следующим способом:

  1. Откройте ту таблицу, в которой нужно произвести расчет.
  2. В свободной ячейке поставьте курсор и введите знак «=» без кавычек. Программа автоматически активирует функцию, предназначенную для суммирования чисел в ячейках таблицы.
  3. Щелкните левой кнопкой мыши по той ячейке, данные которой будут применены в расчете. Там, где поставлен знак «=», появится значение из цифр и букв, обозначающее местоположение числа в таблице. При этом буква – это столбец, а цифра – строка. image003-820x572.png
  4. Напечатайте в поле со знаком «=» после адреса ячейки (B3 в примере) «+», затем выберите ячейку для подсчета, кликнув по ней. Проделывайте это с каждым полем, данные которого требуются для сложения.

Чтобы найти сумму чисел в выбранных ячейках, нажмите на клавишу Enter. В поле, где складывались значения расположения данных, появится число – сумма данных.

При пустом значении ячейки или текста в ней программа автоматически проигнорирует данные. В верхней строке возможно вводить формулу вручную после знака «=». Буквенно-цифровое значение ячейки необходимо складывать с помощью «+», при этом неважно, верхний или нижний регистр используется. Для получения результата также нажмите на клавишу ввода.

В программе Excel используются массивы, или данные, которые объединены в группы. Ими являются таблицы с различными значениями. Чтобы узнать сумму целого массива или нескольких больших массивов, используется функция «СУММ»:

  1. Выделите ту ячейку, в которую планируется вставить итоговое значение сложения. Затем кликните по кнопке «Вставить функцию», которая расположена рядом со строкой для формул.
  2. Откроется окно мастера функций. Выделите пункт «СУММ», затем кликните по кнопке «ОК». Чтобы быстро отыскать нужную функцию, можно воспользоваться специальной поисковой строкой.
  3. В появившемся окне определите диапазон ячеек, которые нужно суммировать. Сделать это можно вручную, вписывая их значение. Также можно выделить с помощью левой кнопкой мышки нужные данные прямо из таблицы в программе. В строке аргументов функции отобразится диапазон ячеек, после этого можно подтвердить действие с помощью кнопки «ОК».

В выделенной ячейке появится сумма выбранного массива, а в строке ввода – функция. Если нужно добавить еще один диапазон данных, то для этого необходимо в окне «Аргументы функции» в строке «Число 2» его определить, затем нажать на «ОК». В выбранной ячейке к ранее полученному результату прибавятся новые данные.

Программа Excel позволяет прописать функцию самостоятельно без использования дополнительных диалоговых окон. Чтобы это сделать, выберите нужную пустую ячейку и в строке формул вручную пропишите функцию с диапазоном. Например, =СУММ(B5:B7), чтобы посчитать итог продаж за четверг, пятницу и субботу.

После того, как функция прописана, нужно нажать на клавишу Enter, чтобы программа произвела подсчет. Следует отметить, что перед функцией ставится знак «=», диапазон прописывается в круглых скобках, а между диапазоном ячеек прописывается двоеточие.

Управление функциями в Excel может осуществляться с помощью горячих клавиш, которые введут функцию в выбранную ячейку автоматически. Чтобы вставить функцию =СУММ, действуйте следующим образом:

  1. Выберите пустую ячейку, в которую будет вписана сумма.
  2. Нажмите и удерживайте клавишу Alt, затем один раз нажмите на клавишу «равно» =.
  3. Отпустите Alt. В выделенную ячейку будет вставлена функция СУММ.
  4. Нажмите Enter, чтобы Excel подсчитал выбранный диапазон.

Данное сочетание клавиш работает на Windows. Для операционной системы MacOS функция активируется одновременным нажатием клавиш Shift + Cmd + T.

В программе Excel предусмотрено три разновидности функции СУММ, которые применяются в зависимости от цели. Помимо расчета результата суммирования выбранных ячеек или диапазона ячеек, есть также сложение по условию: СУММЕСЛИ и СУММЕСЛИМН.

Одна из самых простых и часто используемых функций в программе – это автосумма. Чтобы ее применить, сделайте следующее:

  1. Выберите пустую ячейку, в которой пропишется итоговый результат.
  2. Нажмите на иконку знака суммы, которая располагается на панели инструментов.
  3. Программа автоматически выберет диапазон ячеек, а вверху отобразится функция СУММ. Нажмите на клавишу Enter, чтобы увидеть результат.

Если нужно произвести подсчет суммы определенных ячеек, то после нажатия на иконку в панели инструментов мышкой выделите нужные элементы таблицы.

Автосумма подходит в том случае, если необходимо посчитать данные, которые последовательно расположены в одном столбце или одной строке. Если ячейки друг от друга отдалены, то применить инструмент невозможно. Например, если полностью выделить таблицу с несколькими столбцами, то получится сумма каждого столбца или строки по отдельности, а не общий итог.

Excel позволяет одновременно работать с несколькими таблицами, которые расположены на разных листах. Для этого действуйте согласно простой инструкции:

  1. Выберите пустую ячейку на первом листе, затем перейдите в мастер функций так, как описывалось выше.
  2. В окне «Аргументы функции» поставьте курсор в строку Число2, затем перейдите на другой лист программы.
  3. Выделите нужные для подсчета ячейки и кликните по кнопке подтверждения.

В строке функций будет видно, что в формуле задействован еще один лист. При этом программа посчитает все выделенные элементы на разных листах и впишет их в ту ячейку, которая была выбрана.

Встроенные инструменты Excel позволяют создать отформатированную таблицу из данных и взять результат оттуда. Для этого:

  1. Выделите необходимые данные и преобразуйте их в таблицу, нажав на кнопку «Форматировать как таблицу» на панели инструментов. Выберите нужный стиль.
  2. В появившемся окне подтвердите выбранный диапазон ячеек нажатием на кнопку «ОК».
  3. Перейдите на вкладку «Конструктор», нажмите на кнопку «Параметры стилей таблиц» и поставьте галочку напротив пункта «Строка итогов».
  4. Под отформатированной таблицей появится новая строка, в которой отобразится сумма, автоматически рассчитанная программой.

Чтобы узнать сумму в Excel, необходимо научиться пользоваться функциями и формулами расчета. Простые задачи программа выполняет самостоятельно, например, просмотр общего результата в нижней панели или с помощью отформатированной таблицы. В других случаях потребуется ручная настройка инструментов. Кроме того, приложение поддерживают работу с комбинациями горячих клавиш, отчего работа происходит быстрее и удобнее.

Я на данный момент веду несколько таблиц для разных целей, это не считая тех, которые мы ведем совместно с ребятами из отдела с помощью сервиса Google Docs. У меня есть табличка, которая суммирует мои доходы по сравнению с расходами для блога, также я веду финансовый учет планирования расходов и семейного бюджета, и кучу других документов.

Да, конечно для таких целей есть специальные программы, но если честно, то они меня далеко не во всем устраивают в плане функционала, а в excel я могу настроить всё под себя, как я этого пожелаю. Просторы для этого просто громадные. Тем более сами документы можно защитить паролем, что делает работу в этом редакторе еще надежнее, проще и удобнее. В общем не буду вас томить, а как раз расскажу, как в экселе посчитать сумму ячеек

Содержание

Простое сложение

Начем с легенько разминки. Если вам нужно посчитать сyмму каких-то чиcел, то самое простое — это сделать обычный пример. Для этого встаньте на любую ячейку и напишите знак равенства (=), после чего начинайте складывать нужные цифры (=15+6+94+3-10+2). Последним штрихом вам нужно будет жмахнуть клавишу Enter, тогда весь этот математический пример молниеносно преобразуется в решенный ответ.

Сложение каждой ячейки

Для начала мы с вами научимся складывать просто несколько чисел, которые могут находиться в разных местах

  1. Откройте документ excel, где у вас записаны какие-либо значения.
  2. Теперь выберите какое-нибудь свободное место и поставьте туда знак «Равно» (=). В этот момент у вас активировалась функция решения примеров, и неважно каких, сложения или вычитания.
  3. Теперь нажмите на ячeйку, где у вас записано первое число, которое вы хотите использовать для сложения. В том месте, где мы ставили знак «=», должна появится координата этой цифры, т.е. C6 или D2, и т.д. Отлично. Это то, что нам нужно.
  4. Теперь поставьте знак «+» и нажмите на следующую ячейкy с данными, которое вы хотите использовать для сложения. Видите, как меняется значение в том месте, где мы ставили «=»? Да. Теперь там стоят уже две координаты, объединенные плюсом. 
  5. Таким же образом продолжайте искать оставшиеся цифры и когда они закончатся, вам останется нажать Enter и значения, которые вы выбрали суммируются, а сама сумма покажется в ячейке, в которой мы изначально ставили знак равенства. 

Суммирование столбца

Теперь перейдем к самому простому и вкусному. Да, сейчас вы узнаете как суммировать столбец.

Выделите столбeц или его часть, после чего переходите во вкладку «Формулы» и выбирайте там пункт «Автосумма». После этой несложной манипуляции вы увидите сумму всех выделенных вами чисел. Она автоматически встанет в ближайшую свободную ячейку в вашем столбце.

На самом деле даже необязательно, чтобы это был столбец. Это может быть как и строка, так и отдельные ячейки (можно выделить с помощью зажатой клавиши CTRL). Только место появление результата будет другое.

Использование формулы с помощью параметра «СУММ»

Этот способ особенно хорош тогда, когда вам нужно занести результат в определенную ячейку. По крайней мере я пользуюсь этим именно так и доволен как слон. Давайте покажу.

  1. Поставьте курсор в то место, где вы хотите, чтобы отображался ваш результат и поставьте туда уже знакомый нам знак равенства.
  2. Теперь нам нужно выполнить функцию «СУММ». Ее вы можете выбрать в левом верхнем углу листа, нажав на него. Либо вы можете увидеть ее во вкладке «Формулы», а затем выбрать «Математические», и уже там, среди множества других функций, искать заветную СУММ. В общем жмахайте. 
  3. Вам откроется окно с аргументами функции. Здесь вы должны будете выбрать диапазон чисел, которые будете складывать. Например я хочу сложить столбик от А1 до А7. Тогда поставьте курсор в графу «Число 1», а затем выделите нужные ячейки. 
  4. Теперь нажмите Enter и вы увидите, что всё у вас отлично посчиталось. 

Кстати этим же способом вы можете воспользоваться, чтобы посчитать сумму ячеек с разных листов. Давайте расскажу чуть подробнее.

Суммирование с разных листов

  1. Откройте (создайте) новую таблицу, где разные значения будут находиться на разных листах. Сделали: Молодцы. И тогда сразу же поставьте в любую ячейку на любом лиcте знакомый значок «=» и снова выберите функцию «СУММ», как я рассказывал выше.
  2. Теперь, когда у вас открылось окно «Аргументы функции», поставьте курсор в строку «Число 1», после чего выделите нужные значения на первом листe. 
  3. Теперь ставьте курсор в строку «Число 2», переходите на другой лист, и выделяйте все числа там. После этого нажмите ОК

Всё, теперь несмотря на то, что числа находятся разных местах, сумма посчитана. Эта функция делает данный табличный редактор еще удобнее.

Чем мне особенно нравится excel, так это тем, что можно менять параметры формулы на лету. Например, если нам надо одно из участвующих числе уменьшить на две единицы, то соответственно уменьшится на два и вся сумма. Такую штуку  частенько использую в повседневной жизни.

Ну на этом у меня вроде бы всё. Если остались какие-либо непонятки, то спрашивайте. С удовольствием отвечу на интересующие вас вопросы. Так же рекомендую вам подписаться на обновления моего блога, чтобы всегда быть в курсе обо всем новом и интересном. Увидимся с вами в других статьях. Пока-пока!

С уважением, Дмитрий Костин.

Как посчитать сумму в Excel быстро и просто? Чаще всего нас интересует итог по столбцу либо строке. Попробуйте различные способы найти сумму по столбцу, используйте функцию СУММ или же преобразуйте ваш диапазон в «умную» таблицу для простоты расчетов, складывайте данные из нескольких столбцов либо даже из разных таблиц. Все это мы увидим на примерах.

Содержание

Как суммировать весь столбец либо строку.

Если мы вводим функцию вручную, то в вашей таблице Excel появляются различные возможности расчетов. В нашей таблице записана ежемесячная выручка по отделам.

Если поставить формулу суммы в G2

=СУММ(B:B)

то получим общую выручку по первому отделу.

Обратите внимание, что наличие текста, а не числа, в ячейке B1 никак не сказалось на подсчетах. Складываются только числовые значения, а символьные – игнорируются.

Важное замечание! Если среди чисел случайно окажется дата, то это окажет серьезное влияние на правильность расчетов. Дело в том, что даты хранятся в Excel в виде чисел, и отсчет их начинается с 1900 года ежедневно. Поэтому будьте внимательны, рассчитывая сумму столбца в Excel и используя его в формуле целиком.

Все сказанное выше в полной мере относится и к работе со строками.

Но суммирование столбца целиком встречается достаточно редко. Гораздо чаще область, с которой мы будем работать, нужно указывать более тонко и точно.

Суммируем диапазон ячеек.

Важно научиться правильно указать диапазон данных. Вот как это сделать, если суммировать продажи за 1-й квартал:

Формула расчета выглядит так:

=СУММ(B2:D4)

Вы также можете применить ее и для нескольких областей, которые не пересекаются между собой и находятся в разных местах вашей электронной таблицы.

В формуле последовательно перечисляем несколько диапазонов:

=СУММ(B2:D4;B8:D10)

Естественно, их может быть не два, а гораздо больше: до 255 штук.

Как вычислить сумму каждой N-ой строки.

В таблице расположены повторяющиеся с определенной периодичностью показатели — продажи по отделам. Необходимо рассчитать общую выручку по каждому из них. Сложность в том, что интересующие нас показатели находятся не рядом, а чередуются. Предположим, мы анализируем сведения о продажах трех отделов помесячно. Необходимо определить продажи по каждому отделу.

Иначе говоря, нужно, двигаясь вниз, взять каждую третью строчку.

Это можно сделать двумя способами.

Первый – самый простой, «в лоб». Складываем все цифры нужного отдела обычной математической операцией сложения. Выглядит просто, но представьте, если у вас статистика, предположим, за 3 года? Придется обработать 36 чисел…

Второй способ – для более «продвинутых», но зато универсальный.

Записываем

=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(C2:C16)+1;3)=0;C2:C16))

И затем нажимаем комбинацию клавиш CTRL+SHIFT+ENTER, поскольку используется формула массива. Excel сам добавит к фигурные скобки слева и справа.

Как это работает? Нам нужна 1-я, 3-я, 6-я и т.д. позиции. При помощи функции СТРОКА() мы вычисляем номер текущей позиции. И если остаток от деления на 3 будет равен нулю, то значение будет учтено в расчете. В противном случае – нет.

Для такого счетчика мы будем использовать номера строк. Но наше первое число находится во второй строке рабочего листа Эксель. Поскольку надо начинать с первой позиции и потом брать каждую третью, а начинается диапазон со 2-й строчки, то к порядковому номеру её добавляем 1. Тогда у нас счетчик начнет считать с цифры 3. Для этого и служит выражение СТРОКА(C2:C16)+1. Получим 2+1=3, остаток от деления на 3 равен нулю. Так мы возьмем 1-ю, 3-ю, 6-ю и т.д. позиции.

Формула массива означает, что Excel должен последовательно перебрать все ячейки диапазона – начиная с C2 до C16, и с каждой из них произвести описанные выше операции.

Когда будем находить продажи по Отделу 2, то изменим выражение:

=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(C2:C16);3)=0;C2:C16))

Ничего не добавляем, поскольку первое подходящее значение как раз и находится в 3-й позиции.

Аналогично для Отдела 3

=СУММ(ЕСЛИ(ОСТАТ(СТРОКА(C2:C16)-1;3)=0;C2:C16))

Вместо добавления 1 теперь вычитаем 1, чтобы отсчет вновь начался с 3. Теперь брать будем каждую третью позицию, начиная с 4-й.

Ну и, конечно, не забываем нажимать CTRL+SHIFT+ENTER.

Примечание. Точно таким же образом можно суммировать и каждый N-й столбец в таблице. Только вместо функции СТРОКА() нужно будет использовать СТОЛБЕЦ().

Сумма каждых N строк.

В таблице Excel записана ежедневная выручка магазина за длительный период времени. Необходимо рассчитать еженедельную выручку за каждую семидневку.

Используем то, что СУММ() может складывать значения не только в диапазоне данных, но и в массиве. Такой массив значений ей может предоставить функция СМЕЩ.

Напомним, что здесь нужно указать несколько аргументов:

1.       Начальную точку. Обратите внимание, что С2 мы ввели как абсолютную ссылку.

2.       Сколько шагов вниз сделать

3.       Сколько шагов вправо сделать. После этого попадаем в начальную (левую верхнюю) точку массива.

4.       Сколько значений взять, вновь двигаясь вниз.

5. Сколько колонок будет в массиве. Попадаем в конечную (правую нижнюю) точку массива значений.

Итак, формула для 1-й недели:

=СУММ(СМЕЩ($C$2;(СТРОКА()-2)*5;0;5;1))

В данном случае СТРОКА() – это как бы наш счетчик недель. Отсчет нужно начинать с 0, чтобы действия начать прямо с ячейки C2, никуда вниз не перемещаясь. Для этого используем СТРОКА()-2. Поскольку сама формула находится в ячейке F2, получаем в результате 0. Началом отсчета будет С2, а конец его – на 5 значений ниже в той же колонке.

СУММ просто сложит предложенные ей пять значений.

Для 2-й недели в F3 формулу просто копируем. СТРОКА()-2 даст здесь результат 1, поэтому начало массива будет 1*5=5, то есть на 5 значений вниз в ячейке C7 и до С11. И так далее.

Как найти сумму наибольших (наименьших) значений. 

Задача: Суммировать 3 максимальных или 3 минимальных значения.

Функция НАИБОЛЬШИЙ возвращает самое большое значение из перечня данных. Хитрость в том, что второй ее аргумент показывает, какое именно значение нужно вернуть: 1- самое большое, 2 – второе по величине и т.д. А если указать {1;2;3} – значит, нужны три самых больших. Но при этом не забывайте применять формулу массива и завершать комбинацией клавиш CTRL+SHIFT+ENTER.

=СУММ(НАИБОЛЬШИЙ(B2:D13;{1;2;3}))

Аналогично обстоит дело и с самыми маленькими значениями:

=СУММ(НАИМЕНЬШИЙ(B2:D13;{1;2;3}))

3-D сумма, или работаем с несколькими листами рабочей книги Excel.

Чтобы подсчитать цифры из одинаковой формы диапазона на нескольких листах, вы можете записывать координаты данных специальным синтаксисом, называемым «3d-ссылка».

Предположим, на каждом отдельном листе вашей рабочей книги имеется таблица с данными за неделю. Вам нужно свести все это в единое целое и получить свод за месяц. Для этого будем ссылаться на четыре листа.

Посмотрите на этом небольшом видео, как применяются 3-D формулы.

Как видите, у нас имеется 4 одинаковых таблицы. Стандартный метод нахождения выручки за месяц –

=СУММ(неделя1!B2:B8;неделя2!B2:B8;неделя3!B2:B8;неделя4!B2:B8)

В качестве аргументов перечисляем диапазоны данных.

А вот 3D-метод:

=СУММ(неделя1:неделя4!B2:B8)

Мы указываем программе, что нужно произвести вычисления с ячейками B2:B8, находящимися на листах неделя1, неделя2, неделя3, неделя4. Здесь номер листа последовательно увеличивается на 1.

Важное замечание. Вы можете пользоваться 3D-ссылками и в других случаях. К примеру, выражение

=СРЗНАЧ(неделя1!B2:B8;неделя2!B2:B8;неделя3!B2:B8;неделя4!B2:B8)

найдет среднее значение однодневной выручки за месяц.

Поиск нужного столбца и расчет его суммы.

Имеются сведения о продаже товаров, для каждого из них выделен отдельная колонка. Необходимо рассчитать продажи по выбранному товару. Иначе говоря, нам в Экселе нужно рассчитать сумму столбца, но сначала нужно всего лишь найти этот нужный нам столбец среди других аналогичных.

Для поиска и выбора конкретного товара используем весьма популярную комбинацию функций ИНДЕКС+ПОИСКПОЗ.

Расчет суммы в G3 выполним так:

=СУММ(ИНДЕКС(B2:D21;0;ПОИСКПОЗ(F3;B1:D1;0)))

Итак, комбинация ИНДЕКС+ПОИСКПОЗ должны возвратить для дальнейших расчетов набор чисел в виде вертикального массива, который и будет потом просуммирован.

Опишем это подробнее.

ПОИСКПОЗ находит в шапке наименований таблицы B1:D1 нужный продукт (бананы) и возвращает его порядковый номер (иначе говоря, 2).

Затем ИНДЕКС выбирает из массива значений B2:D21 соответствующий номер столбца (второй). Будет возвращен весь столбик данных с соответствующим номером, поскольку номер строки (первый параметр функции) указан равным 0. На нашем рисунке это будет С2:С21. Остается только подсчитать все значения в этой колонке.

В данном случае, чтобы избежать ошибок при записи названия товара, мы рекомендовали бы использовать выпадающий список в F3, а значения для наполнения его брать из B1:D1.

5 способов создать выпадающий список в Excel — рекомендуем ознакомиться.

Сумма столбцов из нескольких таблиц.

Как в Экселе посчитать сумму столбца, если таких столбцов несколько, да и сами они находятся в нескольких разных таблицах?

Для получения итогов сразу по нескольким таблицам также используем функцию СУММ и структурированные ссылки. Такие ссылки появляются при создании в Excel «умной» таблицы.

При создании её Excel назначает имя самой таблице и каждому заголовку колонки в ней. Эти имена затем можно использовать в выражениях: они могут отображаться в виде подсказок в строке ввода.

В нашем случае это выглядит так:

Прямая ссылка Структурированная ссылка (Имя таблицы и столбца)
B2:B21 Таблица2[Сумма]

Для создания «умной» таблицы выделим диапазон A1:B21 и на ленте «Главная» выбираем «Форматировать как таблицу».

Приятным бонусом здесь является то, что «умная» таблица сама изменяет свои размеры при добавлении в нее данных (или же их удалении), ссылки на нее корректировать не нужно.

Также в нашем случае не принципиально, где именно располагаются в вашем файле Excel эти данные. Даже не важно, что они находятся на разных листах – программа все равно найдет их по имени.

Помимо этого, если используемые вами таблицы содержат строчку итогов, то нашу формулу перепишем так:

=СУММ(Таблица2[#Итоги];Таблица3[#Итоги])

И если будут внесены какие-то изменения или добавлены цифры, то все пересчитается автоматически.

Примечание: итоговая строчка в таблице должна быть включена. Если вы отключите её, то выражение вернет ошибку #ССЫЛКА.

Еще одно важное замечание. Чуть выше мы с вами говорили, что функция СУММ должна сложить сумму всех значений в строке или столбце – даже если они скрыты или же фильтр значений не позволяет их увидеть.

В нашем случае, если в таблице включена строка итогов, вы с ее помощью получите сумму только видимых ячеек.

Как вы видите на этом рисунке, если отфильтровать часть значений, то общие продажи, рассчитанные вторым способом, изменятся.

В то время как если просто складывать ячейки и не использовать итоговую строку «умной» таблицы, то фильтр и скрытие отдельных позиций никак не меняет результат вычислений.

Надеемся, что теперь суммировать области данных или же отдельные ячейки вам будет гораздо проще.

Также рекомендуем:

Как посчитать количество пустых и непустых ячеек в ExcelКак сравнить два столбца на совпадения и различияФормула суммы в Excel — несколько полезных советов и примеровФункция СЧЁТЕСЛИМН в Excel с несколькими условиями — объясняем на примерах.СЧЕТЕСЛИ в Excel — примеры функции с одним и несколькими условиямиФункция СУММЕСЛИМН — как суммировать ячейки в Excel, когда много условий?7 примеров использования формулы СУММЕСЛИ в Excel с несколькими условиямиКак проверить правильность ввода данных в Excel?

Функция СУММ относится к категории: «Математические». Нажмите комбинацию горячих клавиш SHIFT+F3 для вызова мастера функций, и вы быстро ее там найдете.

Использование этой функции существенно расширяет возможности процесса суммирования значений ячеек в программе Excel. На практике ее рассмотрим возможности и настройки при суммировании нескольких диапазонов.

Как в таблице Excel посчитать сумму столбца?

Просуммируем значение ячеек A1, A2 и A3 с помощью функции суммирования. За одно и узнаем, для чего используется функция сумм.

  1. После ввода чисел перейдите на ячейку A4. На закладке инструментов «Главная» выберите инструмент «Сумма» в разделе «Редактирование» (или нажмите комбинацию горячих клавиш ALT+=).
  2. Диапазон ячеек распознан автоматически. Адреса ссылок уже введенные в параметры (A1:A3). Пользователю остается только нажать Enter.

В результате в ячейке A4 отображается результат вычисления. Саму функцию и ее параметры можно увидеть в строке формул.

Примечание. Вместо использования инструмента «Сумма» на главной панели, можно в ячейку A4 сразу ввести функцию с параметрами вручную. Результат будет одинаковый.

Поправка автоматического распознания диапазонов

При введении функции с помощью кнопки на панели инструментов или при использовании мастера функций (SHIFT+F3). функция СУММ() относится к группе формул «Математические». Автоматически распознанные диапазоны не всегда являются подходящими для пользователя. Их можно при необходимости быстро и легко поправить.

Допустим, нам нужно просуммировать несколько диапазонов ячеек, как показано на рисунке:

  1. Перейдите в ячейку D1 и выберите инструмент «Сумма».
  2. Удерживая клавишу CTRL дополнительно выделите мышкой диапазон A2:B2 и ячейку A3.
  3. После выделения диапазонов нажмите Enter и в ячейке D4 сразу отобразиться результат суммирования значений ячеек всех диапазонов.

Обратите внимание на синтаксис в параметрах функции при выделении нескольких диапазонов. Они разделены между собой (;).

В параметрах функции СУММ могут содержаться:

  • ссылки на отдельные ячейки;
  • ссылки на диапазоны ячеек как смежные, так и несмежные;
  • целые и дробные числа.

В параметрах функций все аргументы должны быть разделены точкой с запятой.

Для наглядного примера рассмотрим разные варианты суммирования значений ячеек, которые дают один и тот же результат. Для этого заполните ячейки A1, A2 и A3 числами 1, 2 и 3 соответственно. А диапазон ячеек B1:B5 заполните следующими формулами и функциями:

  • =A1+A2+A3+5;
  • =СУММ(A1:A3)+5;
  • =СУММ(A1;A2;A3)+5;
  • =СУММ(A1:A3;5);
  • =СУММ(A1;A2;A3;5).

При любом варианте мы получаем один и тот же результат вычисления – число 11. Последовательно пройдите курсором от B1 и до B5. В каждой ячейке нажмите F2, чтобы увидеть цветную подсветку ссылок для более понятного анализа синтаксиса записи параметров функций.

Одновременное суммирование столбцов

В Excel можно одновременно просуммировать несколько смежных и несмежных столбцов.

Заполняете столбцы, так как показано на рисунке:

  1. Выделите диапазон A1:B3 и удерживая клавишу CTRL так же выделите столбец D1:D3.
  2. На панели «Главная» щелкните по инструменту «Сумма» (или нажмите ALT+=).

Под каждым столбцом автоматически добавилась функция СУММ(). Теперь в ячейках A4; B4 и D4 отображается результат суммирования каждого столбца. Это самый быстрый и удобный метод.

Примечание. Данная функция автоматически подставляет формат ячеек которых она суммирует.

все уроки

В этом руководстве по Excel объясняется, как использовать функцию СУММ(SUM) в Excel, с синтаксисом и примерами.

Содержание

Описание

Функция СУММ возвращает сумму предоставленных значений. Эти значения могут быть числами, ссылками на ячейки, диапазонами, массивами и константами в любой комбинации. SUM может обрабатывать до 255 отдельных аргументов.

Функция СУММ — это встроенная функция Excel, относящаяся к категории математических / триггерных функций. Как функцию рабочего листа, функцию СУММ можно ввести как часть формулы в ячейку рабочего листа.

Функция СУММ на Русском Функция СУММна Английском
СУММ SUM

Синтаксис

Синтаксис функции СУММ=СУММ([Число1], [Число2] ,…)

Первый аргумент является обязательным, другие числа необязательны, и вы можете ввести до 255 чисел в одной формуле.

В Формуле суммы Excel каждый аргумент может быть положительным или отрицательным числовым значением, диапазоном или ссылкой на ячейку. Например:

=СУММ(A1:A100)=СУММ(A1;A2;A5)=СУММ(1;5;-2)

Пример функции СУММ

Давайте посмотрим на несколько примеров функции СУММ в Excel и узнаем, как использовать функцию СУММ в качестве функции рабочего листа в Microsoft Excel:

На изображении выше у нас в столбце А расположены значения, допустим вы хотите сложить значения 2 и 3 строки для этого пишем в ячейке которой вы хотите увидеть результат =СУММ(A2;A3).Если вы хотите суммировать весь диапазон значений то указывайте его через двоеточие, например в нашем случае это будет =СУММ(A2:A6).

Для того чтобы не писать какие ячейки вы хотите суммировать, вы набираете =СУММ( или выбираете эту функцию в окне «Вставка функции» найти его можно на панели меню выбираете «Формулы»->»Вставка функции»

И щелчком мыши с зажатой клавишей CTRL выбираете ячейки которые хотите суммировать, для выбора диапазона CTRL можно не зажимать.

Cумма столбца в эксел

Если вы хотите посмотреть сумму всего столбца и при этом не выводить ее в таблице, то вам нужно щелкнуть по заголовку столбца левой кнопкой мыши и внизу будет вся нужная вам информация, на изображении ниже показано где смотреть.

Таким же способом можно подсчитать сумму нескольких столбцов, просто выделив нужные вам.

Если столбец, который вы хотите суммировать, имеет переменное количество строк (т. е. Новые ячейки могут быть добавлены, а существующие могут быть удалены в любое время), вы можете просуммировать весь столбец, указав ссылку на столбец, без указания нижней или верхней границы , Например: =SUM(B:B), но в этом случае вы не должны помещать формулу «Сумма столбца» в столбец, который вы хотите суммировать потому что это создаст циклическую ссылку на ячейку, и ваша формула СУММ вернет 0.

Автосумма столбца

Если в конце столбца вам необходимо вывести сумму этого столбца то вам необходимо выполнить следующие шаги:

  1. Выделить ячейку в которой будет сумма строк выше
  2. Выбираем в меню «Главная» значек Сумма
  1. После выбора программа выделяет нужный диапазон, проверяем все ли правильно и нажимаем Enter.

Более быстрый способ выполнить автосумму в Excel — использовать 

Alt + =, 

Просто удерживайте клавишу Alt, нажмите клавишу со знаком равенства, а затем нажмите Enter, чтобы завершить автоматически вставленную формулу суммы.

Сумма строки эксел

Чтобы суммировать всю строку с неопределенным числом столбцов, укажите ссылку на всю строку в формуле Excel СУММ, например:

=СУММ(2:2)

Помните, что вы не должны вводить эту формулу «Сумма строки» в любой ячейке той же строки, чтобы избежать создания циклической ссылки, поскольку это приведет к неправильному вычислению, если таковое имеется:

Используемые источники:

  • https://spravkapc.ru/programmy/excel-sum.html
  • https://koskomp.ru/office/microsoft-excel/kak-v-yeksele-poschitat-summu-yacheek/
  • https://mister-office.ru/funktsii-excel/sum-function-excel.html
  • https://exceltable.com/funkcii-excel/primery-funktsii-summ
  • https://gospodaretsva.com/kak-poschitat-summu-v-eksel.html

Оцените статью
Рейтинг автора
5
Материал подготовил
Илья Коршунов
Наш эксперт
Написано статей
134
7th-studio.ru
Добавить комментарий